Bug 216704 - Suggest a name for the disk image file when creating a new domain
Suggest a name for the disk image file when creating a new domain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
: FutureFeature
Depends On:
Blocks: 234654 227613 240441
  Show dependency treegraph
 
Reported: 2006-11-21 11:52 EST by Chris Lalancette
Modified: 2010-10-22 03:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHEA-2007-0637
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:34:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2006-11-21 11:52:01 EST
Description of problem:
When creating a new domain, it would make life a little bit easier if the "disk"
file was pre-populated with a path and filename, probably based on the name of
the domain.  So, since we are putting new guest images in /var/lib/xen/images,
if you named your domain "rhel5", it could suggest something like:

/var/lib/xen/images/rhel5.dsk

Of course, it would still allow you to change the path/name; just having the
default there will make life a little simpler.
Comment 1 RHEL Product and Program Management 2006-11-21 12:00:45 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Bryn M. Reeves 2006-11-21 12:08:41 EST
This is particularly important given the SELinux restrictions onxen images -
there is currently no obvious guidance (short of grepping the policy's file
contexts) and if you choose to create the image in a location forbidden by the
SELinux policy, error reporting is not very clear.

The tapdisk daemon (if using blktap) will recieve AVC denials for the image in
dom0 , but this is reported to the user as an anaconda "no valid devices were
found on which to create new filesystems" in the new domU installation.
Comment 3 Stephen Tweedie 2006-11-21 13:48:24 EST
No.  The mere presence of an example is not going to give the user any clue that
images in a different location are going to fail.

To achieve that, you need either clear instructions, or an unambiguous error
return.  Simply adding an example isn't going to cut it; and if the trap of bad
image file locations is the justification for this feature request, then I
strongly believe it's the wrong solution.  It's definitely worthwhile having the
example, certainly; but the selinux concern warrants a very different fix, one
very much worth having.
Comment 4 Bryn M. Reeves 2006-11-27 11:42:50 EST
It seems like feeding back the error from the guest anaconda to virt-manager is
not an easy problem to fix. 

As a compromise, would it be reasonable to add documentation to the GUI
describing the default location and a validator that checks the path entered and
pops up a warning if it is not labeled correctly or is not in the standard
/var/lib/xen/images path?
Comment 7 Daniel Berrange 2007-02-22 15:37:24 EST
Automatically suggesting a filename under /var/lib/xen/images, based on the name
of the domain is a reasonable suggestion. Will work on a fix in upstream. Should
be feasible to address for RHEL 5.1
Comment 12 Daniel Riek 2007-07-02 16:24:14 EDT
Requesting an exception to add this convenience feature after beta. Minimal
change and very helpful because it helps people to comply with SELinux.
Comment 16 Daniel Berrange 2007-07-12 12:37:48 EDT
Built into virt-manager-0.4.0-2.el5

* Thu Jul 12 2007 Daniel P. Berrange <berrange@redhat.com> - 0.4.0-2.el5
- Suggest a disk name for file backed VMs (rhbz #216704)


$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.4.0-2.el5                  dist-5E-qu-candidate  berrange
Comment 20 errata-xmlrpc 2007-11-07 11:34:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0637.html

Note You need to log in before you can comment on or make changes to this bug.