Bug 216710 - Turkish Q Layout console keymap is (nearly) unusable in Fedora
Turkish Q Layout console keymap is (nearly) unusable in Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 12:21 EST by Ozgur M. Homurlu
Modified: 2008-06-04 04:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 06:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Obsolete patch for trq.map (4.80 KB, patch)
2006-11-21 12:21 EST, Ozgur M. Homurlu
no flags Details | Diff
Patch for trq.map (5.40 KB, patch)
2006-11-21 13:33 EST, Ozgur M. Homurlu
no flags Details | Diff
Patch for trq.map (5.25 KB, patch)
2006-11-21 14:14 EST, Ozgur M. Homurlu
no flags Details | Diff

  None (edit)
Description Ozgur M. Homurlu 2006-11-21 12:21:40 EST
Description of problem:

The trq.map (most used variant for Turkish) which is distributed now has a lot 
of serious problems:

1) Characters are hardcoded as numbers for ISO8859-9 encoding instead of as 
names while Fedora uses UTF-8 by default. This means all of the non-ASCII keys 
and symbols don't work in default setup.
2) Control-key combinations are totally wrong and have redundant entries. For 
example C-\ (for sending SIGQUIT) doesn't work if you press control and \. In 
console, those combinations are mapped to random places inconsistently with X 
keyboard map and the actual keyboard standard. As a result using Emacs in 
console even for basic editing is nearly impossible. This is very bad news for 
sysadmins using Emacs since being able to edit files in console is a crucial 
capability.
3) Some important symbols (like Euro currency symbol) are missing.

I'm sending a patch for trq.map which I'm using without these problems. First 
of all, it uses names instead of codes for non-ASCII letters and symbols thus 
usable in both UTF-8 and ISO8859-9 locales. I've also fixed all possible 
control key combinations (including possible alt-control combinations, I enjoy 
coding with emacs in console) so they work as they do in X. I've also added 
missing symbols (those exist in Turkish Q specification). Resulting trq.map 
can be loaded with "loadkeys -u" command without giving any error messages and 
works perfectly.


Version-Release number of selected component (if applicable):
kbd-1.12-18

How reproducible:
Always, if trq map is used in console.


Additional info:

I previously sent an incomplete patch for fixing some problems of trq.map for  
bug report #149594 too. That bug report closed with UPSTREAM resolution. 
Unfortunately upstream doesn't release new versions nor respond. As a result 
FC5 and FC6 released with broken trq.map. If you close this bug report with 
UPSTREAM resolution instead of applying the patch again, I'm afraid FC7 and 
and next version of RHEL will be released with a broken keymap for Turkish.
Comment 1 Ozgur M. Homurlu 2006-11-21 12:21:40 EST
Created attachment 141796 [details]
Obsolete patch for trq.map
Comment 2 Ozgur M. Homurlu 2006-11-21 13:33:20 EST
Created attachment 141805 [details]
Patch for trq.map

Added alt-altgr bindings for Emacs (e.g. to produce M-\). They require pressing
Altgr before pressing Alt but better than nothing. Loads and works without
problem.
Comment 3 Ozgur M. Homurlu 2006-11-21 14:14:24 EST
Created attachment 141811 [details]
Patch for trq.map

Removed some of alt-altgr bindings which don't work with Emacs. Kept working
ones.
Comment 4 Miloslav Trmač 2006-11-26 11:10:46 EST
Thanks for the patches.

I'm afraid it is too late for RHEL5.  Anyway, I have pinged the upstream
developer, let's give him a few more weeks...
Comment 5 Ozgur M. Homurlu 2008-01-06 20:02:17 EST
I suppose we have given upstream enough weeks. I'm sure that he's aware of the
situation because he sent me a thank you mail just after Miloslav Trmac wrote
comment #4. As I stated previously, default keyboard map for Turkish is in very
unusable state and since upstream doesn't fix it, I think it's your
responsibility to apply the patch to kbd package.
Comment 6 Ozgur M. Homurlu 2008-02-26 18:03:28 EST
Thank you.
Comment 7 Ozgur M. Homurlu 2008-06-04 04:26:03 EDT
This patch has been applied to upstream kbd 1.14.1:

kbd 1.14.1 Release Notes:
http://lists.altlinux.org/pipermail/kbd/2008-March/000043.html

Note You need to log in before you can comment on or make changes to this bug.