Bug 216743 - opensslconf-i386 should include stddef
Summary: opensslconf-i386 should include stddef
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openssl   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-21 19:50 UTC by Krzysio (Chris) Leszczynski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 21:32:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Krzysio (Chris) Leszczynski 2006-11-21 19:50:13 UTC
Description of problem:
openssl functions use size_t without the proper definition

Version-Release number of selected component (if applicable):
openssl-devel-0.9.8b-8

How reproducible:
Always (but trivial to avoid)


Steps to Reproduce:
1.
/bin/echo -e '#include <openssl/sha.h>\nint main(){return 0;}'|gcc  -x c -

Actual results:
/usr/include/openssl/sha.h:109: error: expected declaration specifiers or ‘...’
before ‘size_t’

Additional info:
This is a low-priority bug because the effect can be easily avoided by including
almost any other header before openssl/sha.h
However it could be patched by adding 
#include <stddef.h>
to /usr/include/openssl/opensslconf-i386.h

Comment 1 Tomas Mraz 2006-11-21 21:32:19 UTC
This is kind of bug which doesn't make sense to resolve just in Fedora. This
should be reported upstream.

Please use:
http://www.openssl.org/support/rt2.html



Note You need to log in before you can comment on or make changes to this bug.