Bug 21675 - anconda fails during Install from harddisk
anconda fails during Install from harddisk
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-04 07:55 EST by Fiji
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 16:34:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fiji 2000-12-04 07:55:10 EST
When installing REDHAT Linux 7.0 anconda shuts down when searching rpm 
pagages. Dumping the text below.

A posible cause could be that when you download the instimge directory to 
a FAT32 partition it results that there a 2 Files which windows considers 
igual because it does not deferenciate between Capital leters and small 
leters (as i know nor does DOS):

GTK.py    and  GTK.pyc 
gtk.py         gtk.pyc 

They are located in the /instimage/usr/lib/python1.5/site-packages 
directory.

------- anaconda Dump -----------------

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: ghostscript

Local variables in innermost frame:
self: <comps.HeaderList instance at 8313610>
item: ghostscript

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 Michael Fulbright 2000-12-04 11:11:36 EST
Passing to QA to reproduce.
Comment 2 Brock Organ 2000-12-04 16:34:35 EST
internal tests using the new downloadable ISOs will solve this problem ... it
should be a feature for the next release ... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.