Bug 216775 - Obtaining dynamic ks.cfg does not reconfigure network
Obtaining dynamic ks.cfg does not reconfigure network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 17:33 EST by Joe Ogulin
Modified: 2008-01-18 12:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 12:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CGI script used to generate dynamic KS file (3.91 KB, application/x-perl)
2006-11-21 17:33 EST, Joe Ogulin
no flags Details

  None (edit)
Description Joe Ogulin 2006-11-21 17:33:07 EST
Description of problem:
When obtaining the kickstart file from a web source, the network device is not
reconfigured to match what comes in with the kickstart file.

Yes, I know the network is configured initially using DHCP, but there is a
network command in the kickstart file that specifies a static IP address, and it
is not applied prior to attempting NFS mounts.

Version-Release number of selected component (if applicable):
Fedora Core 6 (possibly prior versions as well)

How reproducible:

Steps to Reproduce:
1. Place a CGI script on a local web server to provide the kickstart file.
(Script I use is attached.)
2. Set up an NFS server that restricts access to a limited set of IP addresses
3. Set up the DHCP server to send out addresses not in the exports list from 2.
4. Boot a cd, and enter:
linux ks=http://www.example.com/cgi-bin/ks.pl?option1=x&option2=y
 
  
Actual results:
Could not mount NFS file system because the IP address is still that assigned by
the DHCP server

Expected results:
eth0 is configured with the kickstart-specified information once the kickstart
file is obtained

Additional info:
Comment 1 Joe Ogulin 2006-11-21 17:33:07 EST
Created attachment 141843 [details]
CGI script used to generate dynamic KS file
Comment 2 Joe Ogulin 2006-11-22 11:43:52 EST
the boot/install line should read:
linux
ks=http://www.example.com/cgi-bin/ks.pl?ip=w.x.y.z&desktop=kde&hostname=workstation
or something similar
Comment 3 Chris Lumens 2008-01-18 12:18:11 EST
This should be fixed in F9.  Loads of network config fixes have gone in.

Note You need to log in before you can comment on or make changes to this bug.