Bug 216808 - RFE: Subscribe to channels via yum/rhn-plugin command
RFE: Subscribe to channels via yum/rhn-plugin command
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jiri Kastner
: FutureFeature, Reopened
: 459432 (view as bug list)
Depends On: 540544
Blocks: 557292 437822 459432
  Show dependency treegraph
 
Reported: 2006-11-21 20:39 EST by John T. Rose
Modified: 2010-10-22 03:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John T. Rose 2006-11-21 20:39:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061105 Red Hat/1.0.6-0.1.el4 SeaMonkey/1.0.6

Description of problem:
We have hundreds of users who only use their RHN accounts for two purposes, both of which I'd like to see incorporated into up2date so these accounts and the overhead of creating and managing them can be eliminated.

Please consider adding the ability to subscribe to and unsubscribe from specified channels via the command line so a visit to the RHN website isn't required to accomplish this task. Perhaps this can be accomplished via the API, but typical users are fairly comfortable using up2date so having this functionality in up2date seems natural and would be very helpful to our organization.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. na
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Máirín Duffy 2007-01-24 15:21:26 EST
specifically consider the custom channel use case where installation numbers
wouldn't be of much help.
Comment 4 Richard Friedman 2007-04-12 10:42:46 EDT
Also, we should consider this for 5.1 and put it on the API list request.  
Comment 5 Máirín Duffy 2007-10-18 21:59:04 EDT
this was filed under RHEL 5 beta. Moving this to RHEL 5.1, although at this
point 5.2 is likely more appropriate (I apologize for missing that this was
misfiled).

Also, please note that adding a Satellite API call would not help many customers
needing this feature, especially University customers, because it would require
a login/password to the Satellite to run the API script client-side (API scripts
require a Satellite login/pass to run) and some universities prefer to not give
their users login access to the Satellite.
Comment 6 RHEL Product and Program Management 2007-10-18 22:05:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Máirín Duffy 2007-10-18 22:14:42 EDT
note: this affects hosted and satellite customers...
Comment 8 Red Hat Bugzilla 2007-10-25 20:50:40 EDT
User jslagle@redhat.com's account has been closed
Comment 9 RHEL Product and Program Management 2007-11-02 21:36:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 RHEL Product and Program Management 2007-11-05 16:42:38 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 
Comment 11 Jeremy West 2008-05-19 17:04:57 EDT
Could we have additional understanding on why this was declined?

Thanks!
Comment 12 daryl herzmann 2008-05-19 17:21:51 EDT
Hi Jeremy,

The code has been in the up2date client for a while, just never bubbled up to
the UI.  Check out line 317 of /usr/share/rhn/up2date_client/rhnChannel.py

def subscribeChannels(channels,username,passwd):
def unsubscribeChannels(channels,username,passwd):


daryl
Comment 17 RHEL Product and Program Management 2008-06-04 18:50:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 31 Subhendu Ghosh 2009-10-23 19:30:27 EDT
*** Bug 459432 has been marked as a duplicate of this bug. ***
Comment 35 Miroslav Suchý 2009-11-24 11:32:51 EST
Created new script spacewalk-channel (comes with man page Jan :)
This script has options --add, --remove and --list. For all but --list is mandatory to specify username and password. The same you use for login to RHN webUI. So even if you are root, you still have to authenticate yourself. And when you know that username/password you can add/remove those channel in webUI already. Therefore this script do not weaken security in any direction.

This script will be included in package rhn-setup.

This script use backend API call subscribeChannel and unsubcribeChannel which unfortunatelly contain bug in authorization part. It is reported as BZ 
540974 and BZ 540544, but it will mean this script will be functional only if used against rhn.redhat.com and RHN Satellite 5.3.1 and higher.
Comment 47 errata-xmlrpc 2010-03-30 04:43:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0270.html

Note You need to log in before you can comment on or make changes to this bug.