Bug 21684 - cproto chokes on some standard header files
Summary: cproto chokes on some standard header files
Status: CLOSED DUPLICATE of bug 20535
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cproto   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-04 16:24 UTC by John Bollinger
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 16:24:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Bollinger 2000-12-04 16:24:42 UTC
cproto reports numerous error messages when it processes some of the
standard C library
header files.  These files are processed because of their direct or
indirect inclusion in a
specified source file.  The errors occur without passing any options to
cproto, i.e.
"cproto *.c > protos".  cproto seems to successfully process the specified
source files
despite reporting dozens of parse errors in /usr/include/bits/types.h,
/usr/include/libio.h,
/usr/include/stdio.h, /usr/include/sys/types.h, /usr/include/fcntl.h, and
probably others.
Many, but not all, of the errors seemed to be related to internally defined
types, such as
__uid_t and __u_int.  I have assigned "low" severity to this bug because it
does not seem
to interfere with the program performing its function, but the multitude of
error messages is
likely to confuse and alarm some users.

I'm using cproto 4.6-3 and glibc-devel 2.1.3-19.

Comment 1 Bill Nottingham 2000-12-05 16:03:54 UTC

*** This bug has been marked as a duplicate of 20535 ***


Note You need to log in before you can comment on or make changes to this bug.