Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Currently when Apply Ansible Roles is executed on multiple machines and any of them is unreachable all subtasks will fail just because the unreachable one.
This behaviour is confusing as it fails also on hosts which apply ansible roles successfully.
Version-Release number of selected component (if applicable):
Satellite 6.12
How reproducible:
Always
Steps to Reproduce:
1. Have host a and b
2. Power Off host b
3. Run Ansible Roles on both a and b
Actual results:
Both sub-tasks are in Failed state even though it was executed on host a successfully.
Expected results:
Only sub-task of host b should fail because it is unreachable, sub-task on host a should be marked as successful.
Additional info:
Job Template: Ansible Roles - Ansible Default
"""
---
- hosts: all
ignore_unreachable: true <<<<< add this line
pre_tasks:
- name: Display all parameters known for the Foreman host
debug:
var: foreman
tags:
- always
tasks:
- name: Apply roles
include_role:
name: "{{ role }}"
tags:
- always
loop: "{{ foreman_ansible_roles }}"
loop_control:
loop_var: role
"""
Description of problem: Currently when Apply Ansible Roles is executed on multiple machines and any of them is unreachable all subtasks will fail just because the unreachable one. This behaviour is confusing as it fails also on hosts which apply ansible roles successfully. Version-Release number of selected component (if applicable): Satellite 6.12 How reproducible: Always Steps to Reproduce: 1. Have host a and b 2. Power Off host b 3. Run Ansible Roles on both a and b Actual results: Both sub-tasks are in Failed state even though it was executed on host a successfully. Expected results: Only sub-task of host b should fail because it is unreachable, sub-task on host a should be marked as successful. Additional info: Job Template: Ansible Roles - Ansible Default """ --- - hosts: all ignore_unreachable: true <<<<< add this line pre_tasks: - name: Display all parameters known for the Foreman host debug: var: foreman tags: - always tasks: - name: Apply roles include_role: name: "{{ role }}" tags: - always loop: "{{ foreman_ansible_roles }}" loop_control: loop_var: role """