Bug 216871 - tg3: Could not obtain valid ethernet address, aborting.
tg3: Could not obtain valid ethernet address, aborting.
Status: CLOSED DUPLICATE of bug 204916
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 09:17 EST by Dennixx
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 10:13:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennixx 2006-11-22 09:17:26 EST
I just installed an HP Proliant DL 380 G3 with RHEL4. This worked fine until   
applied all latest patches from RHN. After that, the system cannot get   
the Ethernet address for the NIC and the rest of the init of the NIC   
fails subsequently. The tg3 driver is used. 
This problem happens once out of two reboots.   
   
Boot once, it works   
Reboot, it doesn't work   
Reboot, it works   
Reboot, it doesn't work   
[...]   
   
In dmesg, I can find the following for the problem boot:    
===    
tg3: Could not obtain valid ethernet address, aborting.    
tg3: probe of 0000:02:01.0 failed with error -22    
===    
And this for the OK boot:    
===    
eth0: Tigon3 [partno(TBD) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit)    
10/100/1000BaseT Ethernet 00:0b:cd:f4:1a:67   
===   
   
I reverted back to kernel 2.6.9-34.ELsmp which seems to solve the problem for  
the time being.
Comment 1 John W. Linville 2006-12-05 10:13:29 EST

*** This bug has been marked as a duplicate of 204916 ***

Note You need to log in before you can comment on or make changes to this bug.