Bug 216919 - Fechmail fails because /etc/hosts file is faulty
Summary: Fechmail fails because /etc/hosts file is faulty
Status: CLOSED DUPLICATE of bug 211800
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-22 17:53 UTC by Martin Donald
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 16:38:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Donald 2006-11-22 17:53:08 UTC
Description of problem:

Yesterday I updated my computer from Fedora Core 5 to Fedora Core 6. I
could then not access my email by POP3. I found the cause of the
problem this morning; the file /etc/hosts had been set wrongly during
installation.

The /etc/hosts file was:

  /etc:
  -rw-r--r--   2 root root     140 Nov 21 21:37 hosts~

# Do not remove the following line, or various programs
# that require network functionality will fail.
::1	localhost.localdomain	localhost

And my troubles with fetchmail were:

/home/mhd: fetchmail
2 messages for m37907441-1 at pop.1and1.com (4675 octets).
reading message m37907441-1@pop.1and1.com:1 of 2 (1885 octets) .fetchmail: SMTP
connect to localhost failed
fetchmail: SMTP transaction error while fetching from m37907441-1@pop.1and1.com
and delivering to SMTP host localhost
fetchmail: Query status=10 (SMTP)
fetchmail: No mail for m37907441-3 at pop.1and1.com
/home/mhd: 
/home/mhd: 

Before upgrading I had saved my /etc directory so I was able to find
my previous /etc/hosts file and copy over to the /etc directory

  /etc:
  -rw-r--r--   1 root root     146 Nov 22 09:16 hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1	localhost.localdomain	localhost

Fetchmail now worked

/home/mhd: 
/home/mhd: fetchmail
2 messages for m37907441-1 at pop.1and1.com (4675 octets).
reading message m37907441-1@pop.1and1.com:1 of 2 (1885 octets) . flushed
reading message m37907441-1@pop.1and1.com:2 of 2 (2790 octets) .. flushed
fetchmail: No mail for m37907441-3 at pop.1and1.com
/home/mhd: 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Andre Robatino 2006-11-22 18:35:29 UTC
  This is a duplicate of bug #211800.  Basically, /etc/hosts should read

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       localhost.localdomain   localhost
::1     localhost6.localdomain6 localhost6

right after installation.  Try this version to see if it works.

Comment 2 David Cantrell 2006-11-27 16:38:11 UTC

*** This bug has been marked as a duplicate of 211800 ***

Comment 3 D. Hugh Redelmeier 2007-01-13 19:05:22 UTC
me too.  See https://www.redhat.com/archives/fedora-list/2007-January/msg01738.html


Note You need to log in before you can comment on or make changes to this bug.