Bug 216967 - yum install kernel, installed 32- AND 64-bit kernels
Summary: yum install kernel, installed 32- AND 64-bit kernels
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 6
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-22 22:08 UTC by Andrew Cagney
Modified: 2014-01-21 22:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 13:56:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Cagney 2006-11-22 22:08:30 UTC
Description of problem:

In addressing another bug, typed:
yum install kernel, it installed both 32- and 64-bit kernels simultaneously. 
After that machine was a right mess - deleting the 32-bit kernel deleted the
only initrd thingie file.

Comment 1 Seth Vidal 2006-11-22 22:36:18 UTC
1. how does having multiple kernels installed make the machine a problem?
2. is there some other 'more correct' behavior?

Comment 2 David Woodhouse 2006-11-23 07:25:25 UTC
These are multiple kernels with the same n-v-r but just different architectures.
And since only one of them works, yes it's a problem.

Doesn't yum a have special-case to avoid installing more than one kernel, so it
doesn't install both x86_64 and i386 kernels or both ppc and ppc64 kernels
simultaneously?

Comment 3 Andrew Cagney 2006-11-23 15:04:18 UTC
This resulted in a reboot loading the 32-bit kernel I believe; not good.


Comment 4 Seth Vidal 2008-03-12 13:56:43 UTC
In current yum you can set multilib_policy=best in your yum.conf to make it use
the ppc32 arch ONLY unless you explicitly specify ppc64. This should ameliorate
the problem if not outright fix it.




Note You need to log in before you can comment on or make changes to this bug.