Bug 216975 - Virtual Machine Manager won't launch
Virtual Machine Manager won't launch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 17:35 EST by Tim McConnell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.6-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 17:42:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of error (30.42 KB, image/png)
2006-11-22 17:35 EST, Tim McConnell
no flags Details

  None (edit)
Description Tim McConnell 2006-11-22 17:35:26 EST
Description of problem:
Virtual Machine Manager won't launch 

Version-Release number of selected component (if applicable):

virt-manager-0.2.6-1.fc6

How reproducible: Attempt to launch Virtual Machine Manager


Steps to Reproduce:
1. In GNOME click Applications -> System Tools -> Virtual Machine Manager
2. Open a connection to local Xen Host 
3. recive error 
"Unable to open a connection to the Xen hypervisor/daemon.

Verify that:
 - A Xen host kernel was booted
 - The Xen service has been started"
  
Actual results:
Recieve error message and then it exits. 

Expected results:
To be able to launch Virtual Machine Manager to create a Virtual machine

Additional info:
This occurs when attempting to log in as "ROOT" or as an unprivleged user. 
I have the following packages installed: 
libvirt-0.1.7-2
gtkhtml3-3.12.1-1.fc6
gtk-sharp-1.0.10-12.fc6
gtk-sharp2-gapi-2.10.0-3.fc6
gtk-sharp2-2.10.0-3.fc6
gtkhtml2-2.11.0-3
gtkspell-2.0.11-2.1
gtksourceview-sharp-2.0-24.fc6
gtksourceview-1.8.0-1.fc6
gtk+-1.2.10-55.fc6
gtk2-2.10.4-4.fc6
gtk2-engines-2.8.0-1.fc6
gtk-doc-1.7-1.fc6
gtkglext-1.2.0-4.fc6
gtk+-devel-1.2.10-55.fc6
gtk-sharp2-doc-2.10.0-3.fc6
gtk2-devel-2.10.4-4.fc6
gtkmm24-2.10.2-1.fc6
gtkhtml3-devel-3.12.1-1.fc6
pygtk2-codegen-2.10.3-2.fc6
pygtk2-libglade-2.10.3-2.fc6
pygtk2-2.10.3-2.fc6
pygtk2-devel-2.10.3-2.fc6

2.6.18-1.2849.fc6xen #1 SMP Fri Nov 10 13:56:52 EST 2006 i686 athlon i386 GNU/Linux

As far as the Virtual Machine Manager's web site the only thing I don't have
installed is a program called "cobbler" and that appears to be for remote
management. 
Please advise if additional files are needed and how to get them.
Comment 1 Tim McConnell 2006-11-22 17:35:26 EST
Created attachment 141959 [details]
Screen shot of error
Comment 2 Daniel Berrange 2006-11-22 19:44:57 EST
Can you verify that you have an entry mapping 'localhost' to 127.0.0.1  in
/etc/hosts.  A number of machines showing this error only have a localhost
mapping for the IPv6 address, which breaks many things including virt-manager

$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost            
localhost.localdomain localhost
$

In anycase, the next virt-manager will have a work around for this issue, by
using the 127.0.0.1 address directly.
Comment 3 Tim McConnell 2006-11-22 21:45:46 EST
I ran the command you requested and here is the output. 
$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1     localhost.localdomain   localhost       

I assume since it has only the IPv6 address I need to either turn off IPv6 or
add the lines to the /etc/hosts file? Please advise which is going to be better. 
Comment 4 Daniel Berrange 2006-11-23 09:54:35 EST
There is no need to turn off IPv6. Simply add the extra '127.0.0.1
localhost.localdomain localhost'  line immediately before the IPv6 entry.

The fact that the IPv4 entry is missing is a known bug in anaconda I believe.
Comment 5 Tim McConnell 2006-11-23 13:18:26 EST
ok corrected the hosts file so now it looks like: 
]$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1    localhost.localdomain localhost
::1     localhost.localdomain   localhost       
tried again and failed (same problem).
Software Updater launched and there were updates for GTK2 & development
installed them rebooted and retried still same problem. 
Next idea??  
Comment 6 Bjoern Wolfgardt 2006-11-26 04:43:47 EST
I have the same problem. I have just corrected my /etc/hosts to
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost            
localhost.localdomain localhost

But I still get the same error! The same problem exsts on my notebook!
Comment 7 Tim McConnell 2006-11-27 12:12:17 EST
I found a way to launch the Virtual Machine Manager, if I right click on the
panel and choose add to panel then choose VM Applet, then click on it I can add
new domains and view existing domains (Domain0) with no errors. 
This leaves me with a couple of questions.
1. Is the applet how you are supposed to add domains? 
2. If the applet is supposed to be the interface for Domain management, why
isn't it launching by default?
3. Why is there nothing in the documentation about the applet?  
Comment 8 Daniel Berrange 2006-11-27 12:39:21 EST
Could you upload the  /root/.virt-manager/virt-manager.log  file after an
*unsuccessfull* attempt at starting virt-manager from the regular Applications
-> System Tools  menu. Hopefully this will give me a clearer indication of
what's failing.

Comment 9 Tim McConnell 2006-11-27 14:43:55 EST
I don't know how helpful this is but the results are:
Thu, 23 Nov 2006 22:32:16 ERROR    Unable to open connection to hypervisor URI
'xen': socket.gaierror (-2, 'Name or service not known')
is there a way to force debugging? 
Comment 10 Daniel Berrange 2006-11-27 14:47:45 EST
Yep, that is exactly the error message I was looking for / expecting - it
basically means we were unable to resolve 'localhost' - which is odd because
you've already fixed your /etc/hosts. I'll try and do some more debugging on
this myself to reproduce it. There's also a definite work around I can put in to
make this non-fatal, even if I can't find out why its happening.
Comment 11 Tim McConnell 2006-11-27 15:15:40 EST
I don't know if this is any help but from my xend.log file it contains:
[2006-11-13 02:50:36 xend 2832] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-13 02:50:36 xend 2832] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-13 02:50:36 xend.XendDomainInfo 2832] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 64820213176L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-13 02:50:36 xend.XendDomainInfo 2832] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-13 02:50:36 xend.XendDomainInfo 2832] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-13 02:50:36 xend.XendDomainInfo 2832] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-13 02:50:36 xend.XendDomainInfo 2832] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-13 02:50:36 xend 2832] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-13 02:50:36 xend 2832] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-13 02:50:37 xend.XendDomainInfo 2832] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-13 03:02:24 xend 2941] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-13 03:02:24 xend 2941] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-13 03:02:24 xend.XendDomainInfo 2941] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 60411918802L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-13 03:02:24 xend.XendDomainInfo 2941] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-13 03:02:24 xend.XendDomainInfo 2941] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-13 03:02:24 xend.XendDomainInfo 2941] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-13 03:02:24 xend.XendDomainInfo 2941] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-13 03:02:24 xend 2941] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-13 03:02:25 xend 2941] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-13 03:02:25 xend.XendDomainInfo 2941] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-13 10:31:35 xend 3086] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-13 10:31:35 xend 3086] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-13 10:31:35 xend.XendDomainInfo 3086] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 62347074790L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-13 10:31:35 xend.XendDomainInfo 3086] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-13 10:31:35 xend.XendDomainInfo 3086] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-13 10:31:35 xend.XendDomainInfo 3086] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-13 10:31:35 xend.XendDomainInfo 3086] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-13 10:31:35 xend 3086] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-13 10:31:36 xend 3086] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-13 10:31:36 xend.XendDomainInfo 3086] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-13 14:56:12 xend 3094] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-13 14:56:12 xend 3094] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 62140039183L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-13 14:56:12 xend 3094] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-13 14:56:12 xend 3094] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-13 14:56:12 xend.XendDomainInfo 3094] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-14 01:41:22 xend 3222] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-14 01:41:22 xend 3222] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 65825670436L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-14 01:41:22 xend 3222] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-14 01:41:22 xend 3222] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-14 01:41:22 xend.XendDomainInfo 3222] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-14 19:39:42 xend 3361] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-14 19:39:42 xend 3361] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 65231897557L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-14 19:39:42 xend 3361] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-14 19:39:42 xend 3361] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-14 19:39:42 xend.XendDomainInfo 3361] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-14 19:52:51 xend 3238] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-14 19:52:51 xend 3238] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-14 19:52:51 xend.XendDomainInfo 3238] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 61790168638L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-14 19:52:52 xend.XendDomainInfo 3238] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-14 19:52:52 xend.XendDomainInfo 3238] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-14 19:52:52 xend.XendDomainInfo 3238] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-14 19:52:52 xend.XendDomainInfo 3238] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-14 19:52:52 xend 3238] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-14 19:52:52 xend 3238] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-14 19:52:52 xend.XendDomainInfo 3238] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-16 01:29:20 xend 3266] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-16 01:29:20 xend 3266] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 63007564088L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-16 01:29:21 xend 3266] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-16 01:29:21 xend 3266] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-16 01:29:21 xend.XendDomainInfo 3266] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-19 18:01:47 xend 3265] INFO (SrvDaemon:190) Xend stopped due to signal 15.
[2006-11-19 18:01:47 xend 5323] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-19 18:01:47 xend 5323] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-19 18:01:47 xend.XendDomainInfo 5323] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 93869853979205L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-19 18:01:47 xend.XendDomainInfo 5323] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-19 18:01:48 xend 5323] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-19 18:01:48 xend 5323] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-19 18:01:48 xend.XendDomainInfo 5323] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-20 12:41:29 xend 3265] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-20 12:41:29 xend 3265] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 64450726679L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-20 12:41:29 xend 3265] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-20 12:41:29 xend 3265] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-20 12:41:29 xend.XendDomainInfo 3265] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch
[2006-11-23 11:01:03 xend 3277] INFO (SrvDaemon:283) Xend Daemon started
[2006-11-23 11:01:03 xend 3277] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] DEBUG (XendDomainInfo:212)
XendDomainInfo.recreate({'paused': 0, 'cpu_time': 63691777720L, 'ssidref': 0,
'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'shutdown_reason':
0, 'dying': 0, 'dom': 0, 'mem_kb': 962500, 'maxmem_kb': -4, 'max_vcpu_id': 0,
'crashed': 0, 'running': 1, 'shutdown': 0, 'online_vcpus': 1, 'blocked': 0})
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] INFO (XendDomainInfo:224)
Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000.
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] WARNING (XendDomainInfo:246) No
vm path in store for existing domain 0
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] DEBUG (XendDomainInfo:712)
Storing VM details: {'shadow_memory': '0', 'uuid':
'00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'on_poweroff':
'destroy', 'name': 'Domain-0', 'xend/restart_count': '0', 'vcpus': '1',
'vcpu_avail': '1', 'memory': '940', 'on_crash': 'restart', 'maxmem': '940'}
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] DEBUG (XendDomainInfo:747)
Storing domain details: {'cpu/0/availability': 'online', 'memory/target':
'962560', 'name': 'Domain-0', 'console/limit': '1048576', 'vm':
'/vm/00000000-0000-0000-0000-000000000000', 'domid': '0'}
[2006-11-23 11:01:04 xend 3277] DEBUG (XendDomain:153) number of vcpus to use is 0
[2006-11-23 11:01:04 xend 3277] INFO (SrvServer:116) unix
path=/var/lib/xend/xend-socket
[2006-11-23 11:01:04 xend.XendDomainInfo 3277] DEBUG (XendDomainInfo:933)
XendDomainInfo.handleShutdownWatch


Comment 12 Daniel Berrange 2006-12-01 16:08:02 EST
I've managed to reproduce the problem at last. The issue is that virt-manager
needs to resolve the local hostname into a FQDN.  This resolution step is
failing & thus causing the whole app to exit. I will put in a fix so that name
resolution failure does not cause the app to crash. 

Meanwhile, you should be able to resolve the problem in one of two ways:

a. Ensure that the name reported by 'hostname' command can be resolved using DNS.
b. Add the name reported by 'hostname' to /etc/hosts against 127.0.0.1 (or the
non-local IP if you have one).
Comment 13 Tim McConnell 2006-12-01 17:27:39 EST
(In reply to comment #12)
> I've managed to reproduce the problem at last. The issue is that virt-manager
> needs to resolve the local hostname into a FQDN.  This resolution step is
> failing & thus causing the whole app to exit. I will put in a fix so that name
> resolution failure does not cause the app to crash. 
> 
> Meanwhile, you should be able to resolve the problem in one of two ways:
> 
> a. Ensure that the name reported by 'hostname' command can be resolved using DNS.
> b. Add the name reported by 'hostname' to /etc/hosts against 127.0.0.1 (or the
> non-local IP if you have one).
> 


Okay, I edited /etc/hosts to show: 
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1     timmieland.private localhost.localdomain        localhost       red1 
timmieland.private
127.0.0.1 timmieland.private    localhost.localdomain localhost         red1 
 and it is still failing. 
Also when I opened the file the 127.0.0.1 was missing again >:( is it possible
SELinux is blocking this?? 
Comment 14 Tim McConnell 2006-12-01 18:20:08 EST
I ask this because SELinux Troubleshooter reports SELinux is preventing /sbin/ip
(ifconfig_t) "write" to pipe:[24040](unconfined_t).
and 
SELinux is preventing /sbin/arping (netutils_t) "write" to pipe:[23285]
(unconfined_t).
I have no idea if those are the ones used by XEN or not. please let me know. 
Comment 15 Daniel Berrange 2006-12-01 18:30:02 EST
No, SELinux doesn't just go around editing /etc/hosts file. There must be some
other process which is munging your hosts file. That SELinux error is totally
unrelated to whether virt-manager starts up or not. If you're worried about the
SELinux AVC messages, then best report those separately against the
selinux-policy module.


I have pushed a new build of virt-manager 0.2.6-2.fc6  to updates-testing. It
should appear in the repository in a few hours time. This will hopefully solve
the startup crash problem.
Comment 16 Bjoern Wolfgardt 2006-12-02 08:07:00 EST
editing my /etc/hosts to:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost
localhost.localdomain localhost
127.0.0.1               Lox-FC6

fixed it.

Thx
Comment 17 Daniel Berrange 2006-12-05 15:21:48 EST
virt-manager-0.2.6-2.fc6  is available in the updates-testing repository. Please
test this build to confirm whether it fixes the problem with virt-manager not
starting up. Assuming no negative reports with this fix, it will be pushed to
'updates' by the end of the week.
Comment 18 Tim McConnell 2006-12-05 21:45:59 EST
The issue appears to be resolved by the new release virt-manager-0.2.6-2.fc6. thanks

Note You need to log in before you can comment on or make changes to this bug.