Bug 21700 - default font in gnome-terminal unreadable at high resolutions
Summary: default font in gnome-terminal unreadable at high resolutions
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-04 21:45 UTC by Ed McKenzie
Modified: 2007-03-27 03:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 03:35:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2000-12-04 21:45:13 UTC
The default fixed font in gnome-terminal is virtually unreadable at higher
resolutions. As GNOME requires at least 800x600, I think fixed is a poor
choice for a default font. A better choice might be lucida-typewriter-bold
or fixed-cronyx-bold. The 8x16 VGA console font is also much more readable
than the current default, at any resolution.

Granted, a number of these fonts don't support the extended characters used
by mc and others, but most of these fonts display blank characters instead,
which is acceptable.

Comment 1 Havoc Pennington 2000-12-04 22:36:19 UTC
Seems reasonable. Will keep the bug open as a TODO item.

Comment 2 Ed McKenzie 2000-12-08 08:54:17 UTC
Looking again, most of those fonts aren't available in a default install.
<plug>I think Courier (adobe) at 14-pt bold would be a fantastic default font
since it has serifs, is readable at every resolution I've tried, and will look
quite nice once gtk and xfree support the render extension. </plug>

Comment 3 Havoc Pennington 2001-07-12 19:13:03 UTC
On second thought, with the current default the terminal barely fits onscreen in
640x480. So there is no way to make everyone happy here. That's why it's a
preference. ;-)


Note You need to log in before you can comment on or make changes to this bug.