Bug 217002 - Audacity UI becomes very slow
Audacity UI becomes very slow
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 21:41 EST by Steven Garrity
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-18 16:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Garrity 2006-11-22 21:41:40 EST
Description of problem:
When opening or creating an Audacity file with 10 or 20 tracks, the interface
becomes extremely slow. Opening menus, scrolling, or any other UI action takes
several seconds to complete.

When you first open audacity with no file open, the UI is normal.

When looking at "top" during the slowness, I see that a process called "xfs" is
taking up the majority of the processor.

Version-Release number of selected component (if applicable):
1.2.5

How reproducible:
Happens everytime I get more than a few tracks going (more noticable with more
tracks.

Steps to Reproduce:
1. Open Audacity
2. import or create 10 or 20 tracks
3. Try menus or other ui elements
  
Actual results:
UI is noticably slow.

Expected results:
Should be as fast as it always is.
Comment 1 Gérard Milmeister 2006-11-23 05:11:04 EST
I doubt I can do anything do about this, but could you put such an audacity
project including its data somewhere, where I can retrieve it?
Comment 2 Gérard Milmeister 2006-11-23 05:28:18 EST
Ok, I tested it, and it is as you say.
On the one hand, we have the component with the tracks which is slow. This is a
problem with audacity itself. On the other hand, menus open slowly. It seems
that, whenever a menu is displayed, the fonts are looked up. This is why the xfs
process gets process time. This seems to be an issue with wxGTK, the toolkit for
producing the GUI for audacity. 
You may try the following:
Replace the line
  FontPath     "unix/:7100"
in your /etc/X11/xorg.conf with
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
then stop the xfs font server and restart X.
Comment 3 Steven Garrity 2006-11-23 17:04:43 EST
I did not have the line
 FontPath     "unix/:7100"
in my xorg.conf (there were no FontPath entries).

I did try adding the lines you suggested, but it had no effect. Should this bug
be filed upstream with Audacity, or does it show up in other apps that uses
wxGTK 1.x widgets?
Comment 4 Gérard Milmeister 2006-11-23 17:38:41 EST
> Should this bug
> be filed upstream with Audacity, or does it show up in other apps that uses
> wxGTK 1.x widgets?
Yes, please do file a bug upstream.

Note You need to log in before you can comment on or make changes to this bug.