Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 2170484

Summary: Unable to lookup AD user from child domain (or "make filtering of the domains more configurable")
Product: Red Hat Enterprise Linux 8 Reporter: Abhijit Roy <abroy>
Component: sssdAssignee: Sumit Bose <sbose>
Status: CLOSED ERRATA QA Contact: shridhar <sgadekar>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 8.6CC: atikhono, bthekkep, dchen, michael.j.lambert, pbrezina, sgadekar, thalman
Target Milestone: rcKeywords: Improvement, Triaged
Target Release: 8.8Flags: pm-rhel: mirror+
Hardware: All   
OS: Linux   
Whiteboard: sync-to-jira
Fixed In Version: sssd-2.9.0-2.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-11-14 15:49:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Abhijit Roy 2023-02-16 13:47:21 UTC
Description of problem:

Unable to lookup AD user from child domain. Filtering of the domains more configurable.


From sssd_$domain.log
-----
(2022-11-17 18:29:10): [be[example.com]] [dp_attach_req] (0x0400): [RID#5] DP Request [adount #5]: REQ_TRACE: New request. [sssd.nss CID #58] Flags [0x0001].
(2022-11-17 18:29:10): [be[example.com]] [dp_attach_req] (0x0400): [RID#5] Number of active DP request: 2
(2022-11-17 18:29:10): [be[example.com]] [sss_domain_get_state] (0x1000): [RID#5] Domain example.com is Active
(2022-11-17 18:29:10): [be[example.com]] [sss_domain_get_state] (0x1000): [RID#5] Domain example.com is Active
(2022-11-17 18:29:10): [be[example.com]] [sdap_id_op_connect_step] (0x4000): [RID#5] reusing cached connection
(2022-11-17 18:29:10): [be[example.com]] [sdap_search_user_next_base] (0x0400): [RID#5] Searching for users with base [DC=example,DC=com]
(2022-11-17 18:29:10): [be[example.com]] [sdap_print_server] (0x2000): [RID#5] Searching 128.0.x.x
(2022-11-17 18:29:10): [be[example.com]] [sdap_get_generic_ext_step] (0x0400): [RID#5] calling ldap_search_ext with [(&(sAMadountName=roy)(objectclass=user)(sAMadountName=*)(objectSID=*))][DC=example,DC=com].
...
(2022-11-17 18:29:10): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://ad03.example.com/DC=ad03,DC=example,DC=com] with fd [21]
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://ad02.example.com/DC=adt02,DC=example,DC=com] with fd [26]
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://adT05.example.com/DC=adT05,DC=example,DC=com] with fd [27]
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://lfwc.example.com/DC=lfwc,DC=example,DC=com] with fd [28]
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://adt04.example.com/DC=adt04,DC=example,DC=com] with fd [29]
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:10): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://ladc.example.com/DC=ladc,DC=example,DC=com] with fd [30]
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://adt01.example.com/DC=adt01,DC=example,DC=com] with fd [31] <--
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x0040): SASL: GSSAPI Error: An invalid name was supplied (Success) <--
(2022-11-17 18:29:11): [be[example.com]] [sdap_rebind_proc] (0x0020): ldap_sasl_interactive_bind_s failed (-2)[Local error] <---
(2022-11-17 18:29:11): [be[example.com]] [sdap_rebind_proc] (0x1000): Failed to bind to [ldap://adt01.example.com/DC=adt01,DC=example,DC=com].
(2022-11-17 18:29:11): [be[example.com]] [sdap_ldap_connect_callback_del] (0x4000): Closing LDAP connection with fd [31].
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2022-11-17 18:29:11): [be[example.com]] [ad_sasl_log] (0x0040): SASL: GSSAPI Error: An invalid name was supplied (Success)
(2022-11-17 18:29:11): [be[example.com]] [sdap_rebind_proc] (0x0020): ldap_sasl_interactive_bind_s failed (-2)[Local error]
(2022-11-17 18:29:11): [be[example.com]] [sdap_rebind_proc] (0x1000): Failed to bind to [ldap://dc.example.com/DC=ladc,DC=example,DC=com].
(2022-11-17 18:29:11): [be[example.com]] [sdap_ldap_connect_callback_del] (0x4000): Closing LDAP connection with fd [30].
----

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Abhijit Roy 2023-02-16 13:51:59 UTC
Hi,

Sumit has provided the testbuild which solves this issue. I am attaching the testbuild here as well.

'ldap_referrals = True'  should not be enabled.

Comment 4 Ding-Yi Chen 2023-03-04 23:31:05 UTC
The more relevant log is

~~~
(2023-01-24 15:23:27): [be[aus.example.com]] [sdap_ldap_connect_callback_add] (0x4000): New connection to [ldap://acct01.aus.example.com/DC=acct01,DC=aus,DC=example,DC=com] with fd [30]
(2023-01-24 15:23:27): [be[aus.example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2023-01-24 15:23:27): [be[aus.example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2023-01-24 15:23:27): [be[aus.example.com]] [ad_sasl_log] (0x4000): SASL: GSSAPI client step 1
(2023-01-24 15:23:27): [be[aus.example.com]] [ad_sasl_log] (0x0040): SASL: GSSAPI Error: An invalid name was supplied (Success)
(2023-01-24 15:23:27): [be[aus.example.com]] [sdap_rebind_proc] (0x0020): ldap_sasl_interactive_bind_s failed (-2)[Local error]
(2023-01-24 15:23:27): [be[aus.example.com]] [sdap_rebind_proc] (0x1000): Failed to bind to [ldap://acct01.us.example.com/DC=acct01,DC=aus,DC=example,DC=com].
~~~

Comment 5 Alexey Tikhonov 2023-03-13 18:11:45 UTC
Upstream PR: https://github.com/SSSD/sssd/pull/6627

Comment 6 Alexey Tikhonov 2023-04-26 10:17:56 UTC
Pushed PR: https://github.com/SSSD/sssd/pull/6627

* `master`
    * 9358a74d3a56c738890353aaf6bc956bfe72df99 - ad: skip filtering if ad_enabled_domains is set

Comment 13 errata-xmlrpc 2023-11-14 15:49:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sssd bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:7127