This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 217069 - /usr/bin/ld: cannot find -lgcj
/usr/bin/ld: cannot find -lgcj
Status: CLOSED DUPLICATE of bug 214195
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 173278
  Show dependency treegraph
 
Reported: 2006-11-23 12:32 EST by Andrew Cagney
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 13:49:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2006-11-23 12:32:55 EST
Description of problem:

Given a minimal install machine with rpms added using (ref:
http://sourceware.org/frysk/build/#fc6 ):

torreja$ sudo yum install -y \
    antlr jdom junit gcc-java gcc-c++ dejagnu \
    libglade-java-devel libvte-java-devel \
    automake xmlto transfig eclipse-ecj dogtail \
    sharutils cvs audit-libs-devel binutils-devel
torreja$ sudo yum install -y \
    glibc-devel.ppc

the command:

torreja$ gcj -m64  -g -O   -o frysk2493/Npe --main=Npe frysk2493/Npe.o
/usr/bin/ld: cannot find -lgcj
collect2: ld returned 1 exit status

fails.  For reference:

$ rpm -qa --queryformat '%{NAME}.%{ARCH}\n' | grep gcj
java-1.4.2-gcj-compat.ppc
libgcj-devel.ppc64
libgcj.ppc
libgcj.ppc64

torreja is in toronto
Comment 1 Andrew Cagney 2006-11-23 12:44:15 EST
work-around?

torreja$ sudo yum install libgcj-devel.ppc
torreja$ rpm -qa --queryformat '%{NAME}.%{ARCH}\n' | grep gcj
libgcj-devel.ppc
java-1.4.2-gcj-compat.ppc
libgcj.ppc
libgcj.ppc64
torreja$ gcj -m64  -g -O   -o frysk2493/Npe --main=Npe frysk2493/Npe.o
torreja$

confused!
Comment 2 Jakub Jelinek 2006-11-23 13:49:22 EST
You want gcc 4.1.1-35 and above, this sounds like a dup of #214195.

*** This bug has been marked as a duplicate of 214195 ***
Comment 3 Andrew Cagney 2006-11-23 14:03:18 EST
$ ssh torreja rpm -q gcc
gcc-4.1.1-30

so yes, likely.  When is 4.1.1-35 gcc available on FC-6?

Note You need to log in before you can comment on or make changes to this bug.