Bug 217080 - Attempting to enable desktop effects crashes X
Attempting to enable desktop effects crashes X
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 15:32 EST by Chris Siebenmann
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 20:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from a crash session (63.29 KB, text/plain)
2006-11-23 15:32 EST, Chris Siebenmann
no flags Details
My xorg.conf file (2.83 KB, text/plain)
2006-11-24 13:32 EST, Chris Siebenmann
no flags Details
Xorg.0.log without a xorg.conf file (and with a crash) (69.11 KB, text/plain)
2006-11-24 13:38 EST, Chris Siebenmann
no flags Details

  None (edit)
Description Chris Siebenmann 2006-11-23 15:32:03 EST
Description of problem:

If I attempt to enable desktop effects, the X server immediately crashes
and/or exits abruptly (I cannot tell which). When this happens, the kernel
spits out the messages:

  [drm:r300_emit_carefully_checked_packet0] *ERROR* Offset failed range check
(reg=4e28 sz=1)
  [drm:r300_do_cp_cmdbuf] *ERROR* r300_emit_packet0 failed

The kernel also spits out this message (but does not crash) if I run
glxgears, and glxgears itself reports:
   libGL warning: 3D driver claims to not support visual 0x4b
   drmRadeonCmdBuffer: -22 (exiting)

A strace of the server is uninformative, with no obvious SIGSEGVs or
anything. The death is sufficiently abrupt to not clear the graphics
from the screen or reset the graphics mode, leaving the text consoles
unusable. However, another server can be started and seems to work
normally.

Hardware platform:

ASUS M2N4-SLI motherboard, Athlon 64 X2 Dual Core Processor 4600+, 2GB
RAM, with what lspci -v reports as a
  ATI Technologies Inc R480 [Radeon X800 GTO (PCIE)]

display controller (with a primary and a secondary PCI presence; the
primary reports in 'lspci -n' as '05:00.0 0300: 1002:5d4f', the secondary
as '05:00.1 0380: 1002:5d6f'). The graphics card is connected via the
analog VGA out to a Dell 1907FP LCD panel, in case that makes a difference.

The crash/abort happens with both an /etc/X11/xorg.conf created by the
Fedora Core 5 installer (this machine was originally FC5 and was then
upgraded), and the default X configuration that I get when I start
the server without an xorg.conf configuration file.

Version-Release number of selected component (if applicable):

I am using FC6 x86_64, up to date with the current errata, and thus
with:
  kernel-2.6.18-1.2849.fc6
  xorg-x11-drv-ati-6.6.3-1.fc6
  mesa-libGL-6.5.1-8.fc6

I have also seen this with the previous version of xorg-x11-drv-ati et al.

This machine has *never* had the ATI binary fglrx drivers installed on
it, and its kernel is untainted from other stuff.

I have tried the current kernel.org 2.6.19-rc6 from the git repository,
up to date as of today (which is I believe a HEAD of 
66c669baa7d70b8d135da67f36c8dba12cea71b8); it behaves the same way.
I have also tried previous kernel.org git kernels, again with the
same results.

How reproducible:

Completely. This happens every time I try to enable desktop effects.

Additional info:

I have a second M2N4-SLI machine, identical except for using an ATI
X300 card ('RV370 5B60 [Radeon X300SE]', PCI ID 1002:5b60 and
1002:5b70), that was previously running Fedora Core 6. During the time
that it was running FC6, it did not have this problem; I could enable
desktop effects and run glxgears with hardware acceleration and without
problems.

(That machine is now running FC5, so I cannot test anything on it any
more.)
Comment 1 Chris Siebenmann 2006-11-23 15:32:04 EST
Created attachment 142020 [details]
Xorg log file from a crash session
Comment 2 Matěj Cepl 2006-11-24 11:41:29 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachments using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card. Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 3 Chris Siebenmann 2006-11-24 13:32:19 EST
Created attachment 142085 [details]
My xorg.conf file
Comment 4 Chris Siebenmann 2006-11-24 13:38:37 EST
Created attachment 142089 [details]
Xorg.0.log without a xorg.conf file (and with a crash)

Note that between my initial report and getting this data, the machine
was moved from the original LCD to a Mitsubishi CRT; I mention it because
it shows up as a difference in this Xorg.0.log. The crash/abort/etc is
still the same.
Comment 5 Adam Jackson 2007-03-27 11:00:05 EDT
I'm not able to reproduce this in FC7t3.  Can you upgrade and verify that this
is still an issue?
Comment 6 Chris Siebenmann 2007-03-28 01:06:51 EDT
I'm not willing to upgrade to a test release on a machine I use for real stuff,
but when FC7 comes out I'll upgrade and see if I can reproduce the problem
there.
Comment 7 Adam Jackson 2007-05-03 15:10:35 EDT
Fair enough.  Moving back to NEEDINFO until then.
Comment 8 Matěj Cepl 2007-07-11 17:24:57 EDT
Chris, Fedora 7 has been released. Could you please upgrade and verify that this
bug is still reproduceable?

Thanks.
Comment 9 Matěj Cepl 2007-08-11 17:22:48 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 10 Matěj Cepl 2007-09-11 20:46:04 EDT
No information requested provided, no joy for anybody -- closing this bug as
INSUFFICIENT_DATA. Reporter, if you could, please, reopen with additional
information.

Note You need to log in before you can comment on or make changes to this bug.