Bug 217082 - Unable to shutdown or reboot from xfce
Unable to shutdown or reboot from xfce
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 16:52 EST by Heiko Adams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.3.99.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 15:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current sudoers file (3.15 KB, application/octet-stream)
2006-11-23 16:52 EST, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2006-11-23 16:52:03 EST
Description of problem:
After installing XFCE4 I'm unable to shutdown or reboot the system from XFCE.
The buttons are grayed out.

Version-Release number of selected component (if applicable):
xfce4-session-4.3.99.2-1.fc6
xfce4-session-engines-4.3.99.2-1.fc6

Steps to Reproduce:
1. Install XFCE
2. Add <username>   ALL=/usr/libexec/xfsm-shutdown-helper to sudoers
3. Try to reboot the system
  
Actual results:
The buttons for reboot or shutdown the system are grayed out

Expected results:
The buttons for reboot or shutdown the system should be enabled
Comment 1 Heiko Adams 2006-11-23 16:52:03 EST
Created attachment 142023 [details]
Current sudoers file
Comment 2 Kevin Fenzi 2006-11-27 23:02:48 EST
Thanks for the bug report. I'll see about trying to get sudoers setup so this
works more transparently. 
Comment 3 Kevin Fenzi 2006-11-28 01:06:46 EST
I've just checked in and built a new version that should hopefully fix this issue. 

It turns out that new Xfce can use HAL shutdown/reboot methods if available. 
I just needed to add the right buildrequirements and enable it. 

Can you check xfce4-session 4.3.99.2-2 once it's pushed out to the mirrors, and 
let me know if that solves the problem? You can also try an unsigned copy direct
from the buildsys at: 
http://buildsys.fedoraproject.org/plague-results/fedora-6-extras/xfce4-session/4.3.99.2-2.fc6
Comment 4 Heiko Adams 2006-11-28 13:35:48 EST
Thanks, the update solved the problem. After updating the xfce4-session packages
I'm able to shutdown and reboot the system from xfce
Comment 5 Kevin Fenzi 2006-11-28 15:03:52 EST
Excellent. Thanks for the bugreport. 

I am going to go ahead and close this bug, but if you spot any problems feel
free to re-open it or file a new bug. 


Note You need to log in before you can comment on or make changes to this bug.