Bug 217092 - apache's apxs utility is broken because of an error in special.mk
apache's apxs utility is broken because of an error in special.mk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 19:12 EST by Boban
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2.4-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 12:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boban 2006-11-23 19:12:58 EST
Description of problem:

Install httpd-devel package, create a sample module with usr/sbin/apxs -g -n foo
and then try to install that module. It gives out error that it cannot find
/etc/httpd/build/instdso.sh. Problem is in line 32 in modules.mk which reads:

$(top_srcdir)/build/instdso.sh SH_LIBTOOL='$(SH_LIBTOOL)' $$i
$(DESTDIR)$(libexecdir);

instead of 

$(top_builddir)/build/instdso.sh SH_LIBTOOL='$(SH_LIBTOOL)' $$i
$(DESTDIR)$(libexecdir);

I changed the line to latter and now it works.
Comment 1 Vlad Safronov 2006-12-07 06:23:55 EST
FC6, httpd-devel-2.2.3-5

I have the same problem. A custom Apache module compiles and installs only if
change Makefile (my was generated in FC4 some time ago):

Index: Makefile
===================================================================
--- Makefile    (revision 838)
+++ Makefile    (working copy)
@@ -4,8 +4,8 @@
 ##

 builddir=.
-top_srcdir=/etc/httpd
-top_builddir=/etc/httpd
+top_srcdir=/usr/lib/httpd
+top_builddir=/usr/lib/httpd
 include /usr/lib/httpd/build/special.mk

/usr/lib/httpd/build/special.mk

I don't know the right way to fix it. Shall it be special.mk or apxs which
generated Makefile with wrong top_srcdir value.
Comment 2 Boban 2006-12-08 05:05:21 EST
For me it helped to change that one line in special.mk. Also, another module
that I was trying to compile was giving out same error, and after changing
special.mk it all works as a charm

Btw, is anybody from redhat/fedora maintainers even reading this?
Comment 3 Joe Orton 2006-12-08 05:33:56 EST
Yes ;) This is fixed in the Raw Hide branch as of a yesterday - thanks for the
report.   I'll leave this open to remember to fix it in a future FC6 httpd update.

The fix used is to:

sed -i '/instdso/s,top_srcdir,top_builddir,' /usr/lib/httpd/build/special.mk

Note You need to log in before you can comment on or make changes to this bug.