Bug 2171242 - python-celery-5.3.0b2 is available
Summary: python-celery-5.3.0b2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-celery
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-02-19 11:35 UTC by Upstream Release Monitoring
Modified: 2023-06-06 06:05 UTC (History)
6 users (show)

Fixed In Version: python-celery-5.3.0~b2-1.fc39 python-celery-5.3.0~b2-1.fc38
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-19 17:01:03 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 5.3.0b2 (#2171242) (721 bytes, patch)
2023-05-31 14:58 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 5.3.0b2 (#2171242) (720 bytes, patch)
2023-06-06 06:05 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-02-19 11:35:16 UTC
Releases retrieved: 5.3.0b2
Upstream release that is considered latest: 5.3.0b2
Current version/release in rawhide: 5.3.0~b1-2.fc38
URL: https://pypi.python.org/pypi/celery

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3795/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-celery

Comment 1 Upstream Release Monitoring 2023-02-19 11:35:19 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Fedora Update System 2023-02-19 16:59:14 UTC
FEDORA-2023-472fae1182 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-472fae1182

Comment 3 Fedora Update System 2023-02-19 17:00:05 UTC
FEDORA-2023-71cf4b0a3d has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-71cf4b0a3d

Comment 4 Fedora Update System 2023-02-19 17:01:03 UTC
FEDORA-2023-472fae1182 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2023-02-19 17:01:06 UTC
FEDORA-2023-71cf4b0a3d has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Upstream Release Monitoring 2023-05-31 14:58:18 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
There is a syntax error in updated specfile. See attached diff for the changes.

Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 205, in build
    raise BuilderException(str(exc), value=output)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 7 Upstream Release Monitoring 2023-05-31 14:58:19 UTC
Created attachment 1968108 [details]
Update to 5.3.0b2 (#2171242)

Comment 8 Upstream Release Monitoring 2023-06-06 06:05:20 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
There is a syntax error in updated specfile. See attached diff for the changes.

Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 205, in build
    raise BuilderException(str(exc), value=output)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 9 Upstream Release Monitoring 2023-06-06 06:05:21 UTC
Created attachment 1969195 [details]
Update to 5.3.0b2 (#2171242)


Note You need to log in before you can comment on or make changes to this bug.