Bug 217128 - ** (gvim:3472): WARNING **: failure: no device event controller found.
** (gvim:3472): WARNING **: failure: no device event controller found.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: atk (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: Reopened
: 228207 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 01:41 EST by Pete Zaitcev
Modified: 2008-03-10 14:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 14:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2006-11-24 01:41:38 EST
Description of problem:

gvim spews messages to standard error:
** (gvim:3472): WARNING **: failure: no device event controller found.

Version-Release number of selected component (if applicable):

vim-X11-7.0.168-1

How reproducible:

100%

Steps to Reproduce:
1. Run gvim
  
Actual results:

[zaitcev@lembas ~]$ gvim Pad
GTK Accessibility Module initialized
[zaitcev@lembas ~]$ 
** (gvim:3484): WARNING **: failure: no device event controller found.


** (gvim:3484): WARNING **: failure: no device event controller found.

Expected results:

No extra messages.

Additional info:

This is a regression in this build.

Messages are generated for every key press and release.

Since I run gvim from command line a lot, it's a big deal for me.
Comment 1 Karsten Hopp 2006-11-24 05:26:26 EST
I don't get those messages with the same vim version.
You're running some kind of accessibility stuff, this message looks like it's
coming from atk.
I'll reassign to atk to get some comments from the maintainer
Comment 2 Pete Zaitcev 2006-11-25 15:31:55 EST
I think it's scim's fault actually. I logged in and out and the messages stopped.
Scim has a daemon component, so I suspect an upgrade made daemon and libraries
mismatched. I'm closing this.
Comment 3 Pete Zaitcev 2006-11-25 23:51:25 EST
Aww. It seems like a real bug after all. It starts happening after a certain
time after login. I don't think I have any accessibility functions enabled.
There's that silly message about "GTK Accessibility Module", and it better
be suppressed, but it seems like a red herring.
Comment 4 Matthias Clasen 2006-12-01 22:13:59 EST
This message does indeed come from at-spi. It indicates that the a11y registryd
died for some reason.
Comment 5 Pete Zaitcev 2006-12-09 01:44:35 EST
Hilarious... Running registryd by hand (after it dies) terminates the login
session. Anyway, now it should be running with ulimit -c 100000, and I hope
you aren't trying any tricks with signal intercept, so we should know why
it exists after 30 hours of uptime.
Comment 6 Pete Zaitcev 2006-12-10 18:11:29 EST
Core was generated by `/usr/libexec/at-spi-registryd'.
Program terminated with signal 6, Aborted.
#0  0x00a2c402 in ?? ()
(gdb) where
#0  0x00a2c402 in ?? ()
#1  0x00d4ec70 in raise () from /lib/libc.so.6
#2  0x00d504c1 in abort () from /lib/libc.so.6
#3  0x00577b32 in g_logv () from /lib/libglib-2.0.so.0
#4  0x00577b69 in g_log () from /lib/libglib-2.0.so.0
#5  0x00577be6 in g_assert_warning () from /lib/libglib-2.0.so.0
#6  0x47046190 in ORBit_RootObject_duplicate_T () from /usr/lib/libORBit-2.so.0
#7  0x470461d6 in ORBit_RootObject_release () from /usr/lib/libORBit-2.so.0
#8  0x47048cfd in CORBA_Object_release () from /usr/lib/libORBit-2.so.0
#9  0x470e4de3 in bonobo_object_release_unref () from /usr/lib/libbonobo-2.so.0
#10 0x0804fd53 in POA_Accessibility_Registry__init ()
#11 0x004e5c6f in _ORBIT_skel_small_Accessibility_EventListener_notifyEvent ()
   from /usr/lib/libspi.so.0
#12 0x47054617 in IOP_start_profiles () from /usr/lib/libORBit-2.so.0
#13 0x4705a785 in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
#14 0x47047b2c in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0
#15 0x47058346 in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#16 0x470589f2 in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#17 0x47059543 in ORBit_skel_class_register () from /usr/lib/libORBit-2.so.0
#18 0x4705a922 in ORBit_handle_request () from /usr/lib/libORBit-2.so.0
#19 0x47043a67 in giop_connection_handle_input () from /usr/lib/libORBit-2.so.0
#20 0x4706151d in link_connection_state_changed ()
   from /usr/lib/libORBit-2.so.0
#21 0x470643fe in link_io_add_watch_fd () from /usr/lib/libORBit-2.so.0
#22 0x0056f1f2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x005721cf in g_main_context_check () from /lib/libglib-2.0.so.0
#24 0x00572579 in g_main_loop_run () from /lib/libglib-2.0.so.0
#25 0x470dfa23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#26 0x0804f045 in POA_Accessibility_Registry__init ()
#27 0x00d3be5c in __libc_start_main () from /lib/libc.so.6
#28 0x0804b021 in POA_Accessibility_Registry__init ()
(gdb) 
Comment 7 Joachim Frieben 2006-12-11 07:24:03 EST
(In reply to comment #0)
This happens also for other "GTK" based applications like "gedit".
The annoying thing about this is that these warnings keep getting
spawned to the console all the time pushing the "real" content
beyond the window limits.
Comment 8 Pete Zaitcev 2006-12-20 19:55:54 EST
Is there a chance for this to get fixed any time soon?

I was unable to get rid of at-spi. It's require by gail, and gail is required
by control-center.
Comment 9 Pete Zaitcev 2006-12-21 20:02:16 EST
You guys are going to laugh really hard, but I found that the accessibility
can be switched off by running gnome-at-properties (it's installed by
control-center). That takes urgency off the issue.
Comment 10 Matthias Clasen 2006-12-21 20:52:47 EST
I'm sorry. I thought you knew that.
Comment 11 Karsten Hopp 2007-02-12 09:42:49 EST
*** Bug 228207 has been marked as a duplicate of this bug. ***
Comment 12 Josh Boyer 2008-03-10 09:16:33 EDT
Is this still valid any longer?  If not, we can probably close this out...
Comment 13 Joachim Frieben 2008-03-10 10:56:01 EDT
I haven't had these warnings in a while .. Currently running
vim-X11-7.1.266-1.fc9.i386.

Note You need to log in before you can comment on or make changes to this bug.