Bug 217129 - GFS2 and ACL bug?
GFS2 and ACL bug?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: GFS (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Whitehouse
:
Depends On:
Blocks: 218478
  Show dependency treegraph
 
Reported: 2006-11-24 02:07 EST by Gary Lindstrom
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.19-1.2895
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 04:31:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel errors for gfs2 with ACL mount option (53.59 KB, application/octet-stream)
2006-11-24 02:09 EST, Gary Lindstrom
no flags Details

  None (edit)
Description Gary Lindstrom 2006-11-24 02:07:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
Steve,

Got this (see attachment to this bz) after mounting the gfs2 volume with acl option.  Not really sure if it is new or related to my previous deadlock problems, but thought I better submit it.  Maybe your latest patches are not in this kernel and this is taken care of in your tree.  I was doing a couple finds.  You will all see a sysreq dump included in case it helps.  Runnig devel version, kernel kernel-devel-2.6.18-1.2849.fc6 and the latest updates to cman, clvm, openais, etc.

FWIW, the find process is hung chewing through 100% CPU, I assume spinning on a lock...


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes


Steps to Reproduce:
Sorta reproducible (intermittant)

1.  Mount gfs2 volume with acl?
2.  use find to find a file

Actual Results:
Find a file (or not) with kernel errors

Expected Results:
Find a file (or not) without kernel errors///

Additional info:
Comment 1 Gary Lindstrom 2006-11-24 02:09:16 EST
Created attachment 142039 [details]
Kernel errors for gfs2 with ACL mount option

Kernel errors and sysreq dump of problem...
Comment 2 Steve Whitehouse 2006-11-24 07:08:23 EST
This is caused by some incorrect logic when checking the acl which hasn't
correctly worked out whether the inode is already locked or not and has tried to
lock it again. I'll try to come up with a patch shortly.
Comment 3 Steve Whitehouse 2006-11-27 04:48:06 EST
I've just pushed a patch to the -nmw git tree to fix this problem.
Comment 4 Steve Whitehouse 2006-11-28 07:00:17 EST
This is the URL of the fix:

http://www.kernel.org/git/?p=linux/kernel/git/steve/gfs2-2.6-nmw.git;a=commitdiff;h=1280e45239c48cc93758fcb862458e139ce340a2

I would have posted it yesterday, but it seems that kernel.org is very slow to
update these days. You can get a plain version from the "plain" link at the top
of the web page.
Comment 5 Steve Whitehouse 2007-01-15 04:31:35 EST
Fixed in FC6 kernel 2.6.19-1.2895

Note You need to log in before you can comment on or make changes to this bug.