Bug 217136 - apt-0.5.15lorg3.2-8.fc6 breaks synaptic
apt-0.5.15lorg3.2-8.fc6 breaks synaptic
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 03:44 EST by David Juran
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.57.2-5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 21:21:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2006-11-24 03:44:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
synaptic depends on libapt-pkg-libc6.4-6.so.2 which no longer is present in apt-0.5.15lorg3.2-8.fc6 which causes an update to fail.

Version-Release number of selected component (if applicable):
apt-0.5.15lorg3.2-8.fc6

How reproducible:
Always


Steps to Reproduce:
1. yum upgrade


Actual Results:
Error: Missing Dependency: libapt-pkg-libc6.4-6.so.2 is needed by package synaptic

Expected Results:


Additional info:
Comment 1 Axel Thimm 2006-11-24 07:56:49 EST
Thanks for the heads-up. apt had to be rebuilt for ppc changes which by itself
doesn't require any dependent package to be rebuilt. But apt has a bad habit of
adding the glibc's version to its libraries' sonames and that changes since the
last build ... :/

A rebuilt has been queued in.

Note You need to log in before you can comment on or make changes to this bug.