Bug 217137 - "vconfig rem" issue when IPv6 forwarding was on
"vconfig rem" issue when IPv6 forwarding was on
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 04:25 EST by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 12:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script to automate the test process (336 bytes, text/plain)
2006-11-24 04:25 EST, Dmitry Butskoy
no flags Details

  None (edit)
Description Dmitry Butskoy 2006-11-24 04:25:02 EST
Description of problem:

It seems that when any vlan interface was configured for IPv6 and for IPv6
*forwarding*, the removing of such interface ("vconfig rem") causes the kernel
network subsystem to freeze, with the message of:

unregister_netdevice: waiting for eth0.9 to become free. Usage count = 1

(here vlan number 9 is just an example).


Tested for both the latest 2.6.18 kernel and previous 2.6.17 (but perhaps the
issue have appeared earlier).

This bug is very very good reproducible.
Note! You will be caused to reboot your machine after the test!


Steps to Reproduce:

On any simple installation with atleast one network interface present.
The steps below is also attached as a file.

modprobe 8021q
vconfig set_name_type DEV_PLUS_VID_NO_PAD
vconfig add eth0 9

modprobe ipv6
ip link set up dev eth0.9
ip addr add 2001:b08:2:280::3:65aa/112 dev eth0.9

echo 1 >/proc/sys/net/ipv6/conf/eth0.9/forwarding
sleep 5
echo 0 >/proc/sys/net/ipv6/conf/eth0.9/forwarding

ip link set down dev eth0.9

vconfig rem eth0.9



Additional info:
Without enabling of forwarding all is OK.
Any type of forward enabling affects (i.e., echo 1 > .../all/forwarding is too).
Without some sleep ("sleep 5") it might not appear.
Seems to be independent of particular network driver (tested on 3c59x and tg3)
Independent of whether vlan iface has an IPv4 config too or not.

I am busy now to deal with kernel upstream myself, therefore, please, confirm
this bug and maybe send it upstream.
Comment 1 Dmitry Butskoy 2006-11-24 04:25:03 EST
Created attachment 142051 [details]
script to automate the test process
Comment 2 Dmitry Butskoy 2007-03-09 12:51:48 EST
2.6.19 -- still not fixed.
Comment 3 Dmitry Butskoy 2007-03-16 12:23:54 EDT
...but in 2.6.20 seems to be fixed!

More tests later...
Comment 4 Dmitry Butskoy 2007-03-19 12:11:20 EDT
Assume fixed now.

Note You need to log in before you can comment on or make changes to this bug.