Bug 217145 - Add support to install FC6 on a Maple board
Summary: Add support to install FC6 on a Maple board
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-24 11:10 UTC by Adrian Reber
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 10:47:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (875 bytes, patch)
2006-11-24 14:23 UTC, Paul Nasrat
no flags Details | Diff

Description Adrian Reber 2006-11-24 11:10:55 UTC
In addition to the recent changes to the kernel to support the Maple platform
with Fedora there are some changes in rhpl required to correctly detect it.
Following short patch does this:

--- /usr/lib/python2.4/site-packages/rhpl/__init__.py   2005-12-19
19:51:29.000000000 +0100
+++ __init__.py 2006-11-22 09:05:47.000000000 +0100
@@ -34,7 +34,8 @@
                 'Shiner'   : 'ANS',
                 'BRIQ'     : 'BRIQ',
                 'Teron'    : 'Teron',
-                'AmigaOne' : 'Teron'
+                'AmigaOne' : 'Teron',
+                'Maple'    : 'pSeries'
                 }
 
     if getArch() != "ppc":
@@ -49,6 +50,12 @@
             break
 
     if machine is None:
+        for line in lines:
+            if line.find('platform') != -1:
+                machine = line.split(':')[1]
+                break
+
+    if machine is None:
         return None
 
     for type in ppcType.items():

The problem on the Maple platform is that in /proc/cpuinfo the line with
"machine" does not exists. Therefore this patch is also looking at the
"platform" line where it says "Maple".

Comment 1 Paul Nasrat 2006-11-24 14:11:01 UTC
Adrian - does this patch from ydl work for you?  I slightly prefer their method

Comment 2 Paul Nasrat 2006-11-24 14:23:16 UTC
Created attachment 142068 [details]
Proposed patch

I think the best method is to use the mapping to pSeries as in your patch and
the modification to check both machine or platform from ydl patch.  This means
we don't have to add additional conditions on if Maple as it's functionally
like pSeries.

Can you confirm this works as I don't have a Maple board.

Comment 3 Adrian Reber 2006-11-24 14:26:14 UTC
Patch looks like it should work. I will verify it sometimes next week and will
let you know.

Comment 4 Adrian Reber 2006-11-30 08:47:57 UTC
Patch verified and it works perfectly.


Note You need to log in before you can comment on or make changes to this bug.