Bug 217156 - installation crashes free ati driver graphic mode
installation crashes free ati driver graphic mode
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 08:30 EST by Aznar
Modified: 2008-01-15 09:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:40:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (1.98 KB, application/octet-stream)
2006-11-24 08:38 EST, Aznar
no flags Details
Xorg log (57.36 KB, text/plain)
2006-11-24 08:59 EST, Aznar
no flags Details
Xorg.conf (1.88 KB, application/octet-stream)
2006-11-25 10:51 EST, Aznar
no flags Details
Xorg 0 log without worg.conf (66.56 KB, text/plain)
2006-11-25 11:38 EST, Aznar
no flags Details
My most recent Xorg.0.log with the latest xorg (62.68 KB, text/plain)
2007-02-01 10:16 EST, Aznar
no flags Details

  None (edit)
Description Aznar 2006-11-24 08:30:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Epiphany/2.16 Firefox/1.5.0.8

Description of problem:
When I try to install Fedora Core 6 in graphic mode, I can't. I have a message which says "too high frequency".
After installing Fedora in text mode, I can't start gdm, the same message. So I installed closed drivers to have GNOME running.
But, some time ago, I tried again to use free drivers and after having remove the closed one I restarted the computer and, I had the bug, "too high frequency" but  the X server restarted and the gdm started. I could use AIGLX with all 3D effects. So now I'm still using open driver, but I have still this bug but the X server seems to restart a second time and works well after.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.3-1.fc6

How reproducible:
Always


Steps to Reproduce:
1.put the install CD in the drive
2.start the installation in graphic mode
3.kernel is been loading
4.then "too high frequency"

Actual Results:
system is down, I can't restart the computer with alt + ctrl + del or by any other means but shutdown it and start it again.

Expected Results:
Installation in graphic mode.

Additional info:
I think this bug impact a lot of Linux distributions, I had a similar problem when I tried to install Debian or Debian-bases distributions.
Comment 1 Aznar 2006-11-24 08:38:16 EST
Created attachment 142063 [details]
lspci

There is may be even a bug in the lspci, in :
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AR [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon 9600]
(Secondary)

When I was using the closed drivers, it said I had an RV360 card.
Comment 2 Aznar 2006-11-24 08:54:35 EST
"too high frequency" is a message coming from the screen, not Fedora nor Linux.
My screen is a Targa Visionary, LCD 17-3(In reply to comment #1)


Comment 3 Aznar 2006-11-24 08:59:21 EST
Created attachment 142064 [details]
Xorg log

my Xorg log
Comment 4 Matěj Cepl 2006-11-24 11:58:43 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachments using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card. Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 5 Aznar 2006-11-25 10:51:17 EST
Created attachment 142115 [details]
Xorg.conf

My Xorg.conf (actually, it's not the defaut xorg.conf as you can see but the
FC5 version, with little modifications)
Comment 6 Aznar 2006-11-25 11:38:36 EST
Created attachment 142116 [details]
Xorg 0 log without worg.conf

The screen works as you surely can see, may be the problem has been solved by
latest drivers. I still have "too high frequency" but just for some seconds,
after "gdm" starts.
Comment 7 Aznar 2006-12-07 01:27:58 EST
Just to know if the bug have been found ...
Comment 8 Aznar 2007-01-14 14:15:51 EST
https://bugs.freedesktop.org/show_bug.cgi?id=7720

This is the bug report for Xorg, may-be it help you.
It seems that the bug comes from the DRI, when I removed
the DRI section in xorg.conf, everything works.
Comment 9 Adam Jackson 2007-01-24 21:03:22 EST
Hm.  That, and the obviously wrong connector information table, would seem to
indicate we're setting up the memory map wrong when DRI is enabled.

Can you attach the X log from starting X without DRI?
Comment 10 Aznar 2007-02-01 10:16:38 EST
Created attachment 147104 [details]
My most recent Xorg.0.log with the latest xorg

I can't find how to specified that I don't want to start with the DRI, in the
xorg.conf ? in Fedora Core 5, it was there and because I used my FC5 xorg.conf
for FC 6, I don't know how FC6 xorg.cong works.
Comment 11 Matěj Cepl 2007-12-10 04:25:10 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 12 Matěj Cepl 2008-01-15 09:40:35 EST
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

{This is mass-closing of all obsolete bugs; if this bug was in your opinion
closed by mistake, please, reopen it with additional information; thanks a lot
and I am sorry for bothering you in such case.}

Note You need to log in before you can comment on or make changes to this bug.