Bug 217165 - System config kickstart would not work with yum+rhn
System config kickstart would not work with yum+rhn
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
: Reopened
: 232214 237253 (view as bug list)
Depends On:
Blocks: 246139 197865 222082 296411 372911 RHEL5u2_relnotes
  Show dependency treegraph
 
Reported: 2006-11-24 10:41 EST by Daniel Riek
Modified: 2013-01-10 05:14 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2008-0343
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2006-11-24 10:41:26 EST
Description of problem:

On a RHEL5 default installation with an rhn backend for yum and no other
yum-repos active system-config-kickstart exits with the following error msg:

system-config-kickstart requires either the base or development yum repository
enabled for package selection.  Please enable one of these in /etc/yum.repos.d
and restart the program.

Package version:
system-config-kickstart-2.6.16-1.el5.noarch

How reproducible:
Run system-config-kickstart on a RHEL5B2 default installation registered to RHN
and no other yum repositories configured.
Comment 1 Daniel Riek 2006-11-24 10:47:31 EST
I see two possible solutions:

Preferred: Make system-config-kickstart work with the RHN backend.
- This is the preferred solution because it is highly inconsistent to require 
  customers to configure non-RHN yum repositories in order to use 
  system-config-kickstart.

Possible workaround: Add "--enable-repo" commandline option to
system-config-kickstart and document that it requires a local yum repo from the
ISOs.
- Currently it seems to require an actual acive rpository - that is does not 
  work at all in a production environment. It needs to be able to work with 
  disabled repositories. So it needs a "--enable-repo" or "--repoid" option
  like other tools to make this woraround possible.
- Still this work-around is highly undesirable as it forces customers to 
  maintain a updated tree somewhere, just to be able to use the tool
Comment 2 Daniel Riek 2006-11-24 10:50:07 EST
One more comment:
The problem is also, that it seems to statically expect the fedora repo layout
with base or development. In RHEL5 the names are different. 
Comment 3 Daniel Riek 2006-11-24 10:57:02 EST
Another update: it actually seems to work with disabled repos, but still more
control would be required.
Comment 5 Chris Lumens 2006-11-27 13:19:08 EST
All s-c-kickstart needs is to be able to get to the default base repository that
holds the information for what's in an actual release.  Making modifications to
use the RHN plugin for this are fine with me, if you can point out what I need
to be doing.  I'm not familiar with how that plugin works.  I'd much rather do
this than add command line options.

Also right now, all plugins are disabled.  I'll have to change that when I make
these other changes.
Comment 6 James Laska 2006-12-05 10:49:36 EST
Doesn't yum abstract the repo's availbale (whether RHN or yum.repo files)?  Do
we just need to have s-c-kickstart get a list of available packages for install?

The strange thing here is that the repository contents are not guarranteed to
match the content of the installation media (this is true for RHN).
Comment 7 Chris Lumens 2006-12-05 11:02:26 EST
James - we don't even really need the available packages, since s-c-kickstart
has never (as long as I've been maintaining it) provided an interface for
package-level selection.  All it needs is a list of all the package groups.  We
just need to be able to init that main screen in pirut.

The whole point of working the pirut screen in was to get rid of the old package
selection screen, with its out of date and unmaintained list of package groups.
 Using pirut at least means we can find the list automatically at runtime.  The
problem code in s-c-kickstart is:

        # If we're on a release, we want to try the base repo first.  Otherwise,
        # try development.  If neither of those works, we have a problem.
        if "base" in map(lambda repo: repo.id, self.repos.listEnabled()):
            repoorder = ["core", "base", "development"]
        else:
            repoorder = ["development", "core", "base"]

I need to figure out what to do here for RHEL.  Any suggestions on working with
the RHN plugin?
Comment 9 James Laska 2006-12-13 09:46:02 EST
jbowes: any thoughts on clumens yum-rhn-plugin question (see comment#7)?
Comment 10 James Bowes 2006-12-13 10:11:38 EST
Ok, the big problem here is that RHN does not understand and has never
understood comps.xml style groups (see, for example, bug #219336), so even with
the plugin working, you won't be able to get a list of package groups.
Kickstarting works because there's a comps.xml file sitting somewhere on disk,
but to RHN it's just a plain file; it's nothing special.

The other issue is that s-c-ks is looking for repos based on their names. In RHN
we've got either a channel label ("rhel-i386-server-5-beta", channel name ("Red
Hat Enterprise Linux (v. 5 for 32-bit x86 Server) Beta"), or description ("Red
Hat Enterprise Linux - Server core components (v. 5 for 32-bit x86) Beta") that
could be used for repo.id. I suppose we could do some hackery to call the base
channel 'core', but come next rhel release, we might have to change things again.

What about grabbing the comps.xml file from the location of the kickstart tree?
I think that is what system-cdinstall-helper does.
Comment 11 Jay Turner 2006-12-13 21:55:26 EST
Seems a little late for a change like this.  Recommend we move to RHEL5.1.
Comment 12 Pete Graner 2006-12-17 01:42:17 EST
We're too late in the game to try and pull this off. Should go in 5.1
Comment 15 Chris Lumens 2006-12-18 16:28:45 EST
This does require a release notes blurb.  In RHEL-5, system-config-kickstart
will not support package selection and deselection.  When
system-config-kickstart is started, the package selection screen will show a
message indicating that it is not supported.  This is because
system-config-kickstart uses yum to gather group information, but does not know
how to configure yum to work with RHN.  As a workaround, people may continue to
update the package sections of their kickstart files by hand. 
system-config-kickstart-2.6.19.1-1 will preserve all package information in any
files it opens and write them back out on save.
Comment 16 Don Domingo 2006-12-18 19:18:58 EST
added to release notes:

<quote>
Currently, system-config-kickstart does not support package selection and
deselection. When using system-config-kickstart, the Package Selection option
indicates that it is disabled. This is because system-config-kickstart uses yum
to gather group information, but is unable to configure yum to connect to Red
Hat Network.

This issue is currently being investigated for resolution by Red Hat Enterprise
Linux 4.92 Update 1. At present, you will need to update package sections in
your kickstart files manually. When using system-config-kickstart to open a
kickstart file, it will preserve all package information in it and write it back
out on save.
</quote>


thanks! 
Comment 17 Chris Lumens 2006-12-19 10:20:27 EST
Surely, you mean Red Hat Enterprise Linux 5 Update 1.
Comment 18 Daniel Riek 2006-12-19 18:20:57 EST
Actually we are not using the RHEL X Update Y naming scheme anymore. It would be
"Red Hat Enterprise Linux 5.1" or "the next minor release".
Comment 22 Jay Turner 2007-01-19 08:39:17 EST
Closing out.  Please ensure there's a 5.1 bug to track resolution of the
original issue.
Comment 23 Chris Lumens 2007-03-14 10:09:41 EDT
*** Bug 232214 has been marked as a duplicate of this bug. ***
Comment 26 Chris Lumens 2007-04-27 10:11:05 EDT
*** Bug 237253 has been marked as a duplicate of this bug. ***
Comment 29 RHEL Product and Program Management 2007-10-16 00:08:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 31 Chris Lumens 2007-12-13 12:05:24 EST
I have a potential fix for this in version control right now.  Please take a
look at the next build of s-c-ks, especially testing the problem cases.
Comment 33 Don Domingo 2008-01-15 19:28:10 EST
adding to RHEL5.2 release notes under "Resolved Issues":

<quote>
system-config-kickstart now supports package selection through the Red Hat
Network plugin.
</quote>

please advise if any further revisions are required. thanks!
Comment 39 Don Domingo 2008-04-01 22:11:04 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 40 errata-xmlrpc 2008-05-21 12:57:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0343.html

Note You need to log in before you can comment on or make changes to this bug.