This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 217174 - tail stopped taking +N argument
tail stopped taking +N argument
Status: CLOSED DUPLICATE of bug 173431
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 12:01 EST by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 13:38:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2006-11-24 12:01:21 EST
Description of problem:

tail +3 fails with:
tail: cannot open `+3' for reading: No such file or directory

Version-Release number of selected component (if applicable):

coreutils-5.97-14.fc7

How reproducible:

100%

Steps to Reproduce:
1. run "tail +3 /etc/hosts"
  
Actual results:

tail does not skip 3 lines, prints error message

Expected results:

tail should skip 3 lines

Additional info:

This breaks Dell BIOS update.

Also, the --help message contains this information:

If the first character of N (the number of bytes or lines) is a `+',
print beginning with the Nth item from the start of each file, otherwise,
print the last N items in the file.  N may have a multiplier suffix:
b 512, k 1024, m 1024*1024.
Comment 1 Tim Waugh 2006-11-24 13:38:46 EST

*** This bug has been marked as a duplicate of 173431 ***

Note You need to log in before you can comment on or make changes to this bug.