This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 217182 - speedstep centrino support not enabled in kernel
speedstep centrino support not enabled in kernel
Status: CLOSED DUPLICATE of bug 211941
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 13:56 EST by Stephen Hemminger
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 19:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Hemminger 2006-11-24 13:56:57 EST
Description of problem:
Since the cpu frequency control for Pentium-M is not enabled by default
in the FC6 kernel (CONFIG_X86_SPEEDSTEP_CENTRINO). There is no frequency
control and laptop always runs full speed.

Version-Release number of selected component (if applicable):
2.6.18-1.2849.fc6

How reproducible:
100%

Steps to Reproduce:
1. boot
2. look for cpufreq in /sys (it's missing)
3. frequency control from gnome-power-manager etc can't work

It works if I build a upstream kernel and enable it.  

Actual results:


Expected results:


Additional info:
Is this intentional or unintentional
Comment 1 Dave Jones 2006-11-24 16:48:31 EST
Hrmm.

$ grep SPEEDSTEP /boot/config-2.6.18-1.2849.fc6 
CONFIG_X86_SPEEDSTEP_CENTRINO=y

Oh, I bet I know what this is.  I bet you've been bitten by the "installer
installs a 586 kernel by default" bug.  
See http://fedoraproject.org/wiki/Bugs/FC6Common  and see if that's the problem.

If that still doesn't get you up and running, attach dmesg, and I'll poke at it
some more.
Comment 2 Stephen Hemminger 2006-11-24 19:25:41 EST

*** This bug has been marked as a duplicate of 211941 ***

Note You need to log in before you can comment on or make changes to this bug.