Bug 217191 - anaconda doesnot find partition-label during update
anaconda doesnot find partition-label during update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 17:20 EST by Leopold Aichinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 16:20:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leopold Aichinger 2006-11-24 17:20:15 EST
Description of problem:

I dried to update my FedoraCore5-Installation to FedoraCore6.
I bootet my system from dvd for installation, and when anaconda found my
fedoracore5-installation I decided for update.
But update failed because anaconda did not find the partition labels from
the LVM-logical volumns.
-----------------------------------------------------------------------------
The interesting part from the anaconda-log:

19:44:14 INFO    : lv is VolGroup00/LogVol00, size of 576
19:44:14 INFO    : lv is VolGroup00/LogVol01, size of 69984
19:44:14 INFO    : lv is VolGroup00/LogVol02, size of 1696
19:44:14 INFO    : lv is VolGroup00/LogVol03, size of 49984
19:44:14 INFO    : lv is VolGroup00/LogVol04, size of 480
19:44:14 INFO    : lv is VolGroup00/LogVol05, size of 20480
19:44:14 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol00 on
/mnt/sysimage
19:44:14 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol01 on
/mnt/sysimage
19:44:14 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol02 on
/mnt/sysimage
19:44:14 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol03 on
/mnt/sysimage
19:44:14 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol05 on
/mnt/sysimage
19:44:15 DEBUG   : isys.py:mount()- going to mount /tmp/hda1 on /mnt/sysimage
19:44:15 WARNING : /usr/lib64/python2.4/site-packages/snack.py:247:
DeprecationWarning: integer argument expected, got float
  self.w.scaleSet(amount)

19:44:16 WARNING : step complete does not exist
19:44:16 INFO    : moving (1) to step findinstall
19:44:16 INFO    : using only installclass _Fedora
19:44:19 WARNING : step installtype does not exist
19:44:19 WARNING : step checkdeps does not exist
19:44:19 WARNING : step dependencies does not exist
19:44:19 INFO    : no /tmp/fcpconfig; not configuring zfcp
19:44:19 INFO    : Detected 1008M of memory
19:44:19 INFO    : Swap attempt of 1000M to 2000M
19:44:19 WARNING : step complete does not exist
19:44:19 INFO    : moving (1) to step partitionobjinit
19:44:19 INFO    : no initiator set
19:44:23 INFO    : pv is /dev/hda2 in vg VolGroup00, size is 238409
19:44:24 INFO    : vg VolGroup00, size is 238400, pesize is 32768
19:44:24 INFO    : lv is VolGroup00/LogVol00, size of 576
19:44:24 INFO    : lv is VolGroup00/LogVol01, size of 69984
19:44:24 INFO    : lv is VolGroup00/LogVol02, size of 1696
19:44:24 INFO    : lv is VolGroup00/LogVol03, size of 49984
19:44:24 INFO    : lv is VolGroup00/LogVol04, size of 480
19:44:24 INFO    : lv is VolGroup00/LogVol05, size of 20480
19:44:24 ERROR   : could not create directory //dev/mapper: Die Datei existiert
bereits
19:44:24 INFO    : moving (1) to step upgrademount
19:44:27 INFO    : going to mount /dev/VolGroup00/LogVol00 on /mnt/sysimage as ext3
19:44:27 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol00 on
/mnt/sysimage
19:44:28 WARNING : fstab file has LABEL=/, but this label could not be found on
any file system
19:44:28 WARNING : fstab file has LABEL=/opt, but this label could not be found
on any file system
19:44:28 WARNING : fstab file has LABEL=/usr, but this label could not be found
on any file system
19:44:28 WARNING : fstab file has LABEL=/var, but this label could not be found
on any file system
19:44:28 WARNING : fstab file has LABEL=/home, but this label could not be found
on any file system
19:44:28 INFO    : trying to mount hda1 on /boot
19:44:28 INFO    : set SELinux context for mountpoint /boot to
system_u:object_r:boot_t:s0
19:44:28 DEBUG   : isys.py:mount()- going to mount /dev/hda1 on /mnt/sysimage/boot
19:44:28 INFO    : trying to mount proc on /proc
19:44:28 INFO    : set SELinux context for mountpoint /proc to None
19:44:28 DEBUG   : isys.py:mount()- going to mount proc on /mnt/sysimage/proc
19:44:28 INFO    : trying to mount sys on /sys
19:44:28 INFO    : set SELinux context for mountpoint /sys to None
19:44:28 DEBUG   : isys.py:mount()- going to mount sys on /mnt/sysimage/sys
19:44:28 INFO    : trying to mount sysfs on /sys
19:44:28 ERROR   : could not create directory /mnt/sysimage//sys: Die Datei
existiert bereits
19:44:28 INFO    : set SELinux context for mountpoint /sys to None
----------------------End anaconda.log ------------------------------------

My /etc/fstab:
----------------------------------------------------------------------------
LABEL=/ 		/                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext2    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=/opt 		/opt                    ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=/usr		/usr                    ext3    defaults        1 2
LABEL=/var		/var                    ext3    defaults        1 2
LABEL=/home		/home			ext3	defaults	1 2
/dev/VolGroup00/LogVol04 swap                   swap    defaults        0 0
/dev/hdc		/mnt/cdrom		iso9660 defaults,user   0 0
-----------------End /etc/fstab-------------------------------------------
The output from the mount-command:
--------------------------------------------------
/dev/root on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda1 on /boot type ext2 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/dm-1 on /opt type ext3 (rw)
/dev/dm-2 on /usr type ext3 (rw)
/dev/dm-3 on /var type ext3 (rw)
/dev/dm-5 on /home type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/hdc on /mnt/cdrom type iso9660 (ro,noexec,nosuid,nodev,user=leo)
/dev/sde1 on /mnt/festplatte type ext3 (rw)
---------------------------------------------------------------------

Original after installation of Fedora Core 5 I had no "LABEL=" in the file
/etc/fstab, so the line:
LABEL=/     /              ext3    defaults        1 1
looked like:
/dev/dm-0   /              ext3    defaults        1 1

I labeled all the logical-volumns with e2label and changed all the
/dev/dm-? stuff in my /etc/fstab to "LABEL=" by hand
and I think this is the problem why anaconda now is not abel to find
the lvm-logical volumns.
If I do a
# dumpe2fs -h /dev/dm-1 
I get the following output:
------------------------------------------------------------------
Filesystem volume name:   /opt
Last mounted on:          <not available>
Filesystem UUID:          37c2cdbe-88f2-4e7f-b078-1c01bdb54246
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype
needs_recovery sparse_super large_file
Default mount options:    (none)
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
...
-------------------------------------------------------------------------

Version-Release number of selected component (if applicable):


How reproducible:
After Fedora Core5 installation:
Label your lvm logical volumns with e2label and change all the
/dev/dm-* stuff in your /etc/fstab to LABEL=TheNameyouGavetotheVolumn
Boot for Installation from the fedoraCore6 dvd and after anaconda found
your old system (fc5) decide for update.


Actual results:
anaconda will fail because anaconda will not recognise your lvm-logical volumns
by the label-names.

Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-11-28 13:30:50 EST
We don't use labels on LVM due to problems that used to exist -- I think those
have been fixed now, so we could probably use them if they're there (but not set
them ourselves)
Comment 2 Chris Lumens 2006-12-01 16:20:42 EST
Committed a fix to rawhide.  Please test a tree with anaconda-11.2.0.4 or later
in it and let me know if this is fixed for you.  If not, feel free to reopen
this bug with additional information.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.