Bug 217223 - Synaptics driver sometimes won't detect touchpad
Synaptics driver sometimes won't detect touchpad
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Depends On:
  Show dependency treegraph
Reported: 2006-11-25 04:39 EST by David Monniaux
Modified: 2008-05-06 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Monniaux 2006-11-25 04:39:46 EST
Description of problem:
Synaptics touchpad had always worked so far. Today I booted up and X wouldn't
start because it could not find the Synaptics touchpad to drive the core
pointer. Tried rebooting several times, no avail. Rebooted under Windows, then
again under Linux, and it worked.

Version-Release number of selected component (if applicable):

How reproducible:
strange occurence

Steps to Reproduce:
1. Boot on a system where core pointer is driven by Synaptics touchpad
2. Wait for X11 to start
Actual results:
X won't start complaining of:
(II) Synaptics touchpad driver version 0.14.4 (1404)
Synaptics no synaptics event device found (checked 12 nodes)
(**) Option "Device" "/dev/input/mice"
(**) Option "SHMConfig" "true"
(**) Option "LeftEdge" "120"
(**) Option "RightEdge" "830"
(**) Option "TopEdge" "120"
(**) Option "BottomEdge" "650"
(**) Option "FingerLow" "14"
(**) Option "FingerHigh" "15"
(**) Option "MaxTapMove" "110"
(**) Option "VertScrollDelta" "20"
(**) Option "HorizScrollDelta" "20"
Query no Synaptics: 6003C8
(EE) Synaptics no synaptics touchpad detected and no repeater device
(EE) Synaptics Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Synaptics"
(II) UnloadModule: "synaptics"

Expected results:
It should start and load Synaptics as follows:
(II) Synaptics touchpad driver version 0.14.4 (1404)
(--) Synaptics auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(**) Option "SHMConfig" "true"
(**) Option "LeftEdge" "120"
(**) Option "RightEdge" "830"
(**) Option "TopEdge" "120"
(**) Option "BottomEdge" "650"
(**) Option "FingerLow" "14"
(**) Option "FingerHigh" "15"
(**) Option "MaxTapMove" "110"
(**) Option "VertScrollDelta" "20"
(**) Option "HorizScrollDelta" "20"
(--) Synaptics touchpad found

Additional info:
Comment 1 Bug Zapper 2008-04-04 00:55:51 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2008-05-06 12:56:56 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.