Bug 217242 - MonoDevelop package from yum is not complete
MonoDevelop package from yum is not complete
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 11:43 EST by Daniel Turner
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 08:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Turner 2006-11-25 11:43:43 EST
Description of problem: MonoDevelop will install, however, when attempting to
build and run one of the sample projects (or any other Gtk-sharp2 based project)
the compiler can never find the type or namespace Gtk.


Version-Release number of selected component (if applicable): 0.12 


How reproducible: Not attempted to reproduce as of yet, seems very reproducible.


Steps to Reproduce:
1. Install MonoDevelop using yum
2. Fire MonoDevelop up
3. Create a new Gnome# 2 project from the samples (File > New Project)
4. Attempt to Run it. It fails here.

Actual results:
Compiler throws error


Expected results:
Sample project should compile and run


Additional info:
I fixed this by running yum install gtk-sharp2*
Comment 1 Paul F. Johnson 2006-11-25 11:58:39 EST
Which build on monodevelop are you using? 0.12-7 certainly has R gtk-sharp2-gapi
in it (this is what is needed for the gnome# 2 stuff)
Comment 2 Daniel Turner 2006-11-25 12:05:34 EST
It was the MonoDevelop found in the repositories, The Help>About menu says that
it is MonoDevelop 0.12.0.0 The Yum install gtk-sharp2* said that it installed
gtk-sharp2-docs and gtk-sharp2-devel. 
Comment 3 Daniel Turner 2006-11-25 12:08:08 EST
Running yum install gtk-sharp2* has NOT fixed the Gnome-sharp problems, however,
Gtk# 2 projects are possible, just not Gnome# will not compile.
Comment 4 Paul F. Johnson 2006-11-25 12:15:10 EST
rpm -qa monodevelop will help here.

I'll look into the problem and should hopefully have a fix at some point soon
Comment 5 Daniel Turner 2006-11-30 13:54:48 EST
[root@localhost $]# rpm -qa monodevelop
monodevelop-0.12-7.fc6
Comment 6 Paul F. Johnson 2006-11-30 20:17:48 EST
monodevelop is currently at version 0.12-8 - I'm not sure if that's the case in
fc6, but it is in rawhide - try the version from there and let me know if it's
still causing a problem
Comment 7 Paul F. Johnson 2006-12-20 17:08:25 EST
Is it still causing you a problem with the 0.12-8 release?
Comment 8 Dino Sangoi 2007-08-15 16:48:26 EDT
This problem seems still present both on F7 and F8T1. Yesterday I needed a
simple program, so I did a 'yum install monodevelop' on F8T1, run it, created a
Gtk project without problems, but when I tried to compile the project, I got the
error "The type or namespace 'Gtk' could not be found. Are you missing a using
directive or assembly reference?(CS0246)". Then I booted to F7, and tried the
same thing, and got the same error.
After looking a bit, I found that installing gtk-sharp2-devel fixes it. I
double-checked it now: a 'rpm -e gtk-sharp2-devel' makes the compilation fail, a
'yum install gtk-sharp2-devel' makes it work again.

So it seems that monodevelop should depend on gtk-sharp2-devel.

Trying the Gnome# 2.0 Project under Samples still fails. Again installing
'gnome-sharp-devel' fixes the error.

Both gtk-sharp2-devel and gnome-sharp-devel are near 4Kb in size each, so I
think is not a big problem.

Instead, to be able to read the gtk documentation, I need to manually install
'gtk-sharp2-doc'. It would be nice to have it pulled automatically, but is a bit
fat and not strictly required...
Comment 9 Paul F. Johnson 2007-11-13 10:25:50 EST
Is this happening with 0.17b2 in rawhide?
Comment 10 Paul F. Johnson 2008-01-06 17:36:44 EST
ping
Comment 11 Bug Zapper 2008-04-04 00:56:14 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.