Bug 217255 - /etc/rc.d/init.d/xend does not write /var/lock/subsys/xend file
/etc/rc.d/init.d/xend does not write /var/lock/subsys/xend file
Status: CLOSED DUPLICATE of bug 234597
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Mark McLoughlin
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 19:42 EST by Peter Backes
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-30 10:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix to /etc/rc.d/init.d/xend (402 bytes, patch)
2006-11-25 19:42 EST, Peter Backes
no flags Details | Diff

  None (edit)
Description Peter Backes 2006-11-25 19:42:12 EST
Description of problem:
/etc/rc.d/init.d/xend does not create/delete a /var/lock/subsys/xend file on
start/stop.

Version-Release number of selected component (if applicable):
xen-3.0.3-0.1.rc3

How reproducible:
always

Steps to Reproduce:
1. Boot in runlevel 3
2. telinit 5

Actual results:
on switching to runlevel 5 it executes xend start.

Expected results:
It shouldn't, since it's already running.

Additional info:
trivial fix attached.
Comment 1 Peter Backes 2006-11-25 19:42:12 EST
Created attachment 142125 [details]
fix to /etc/rc.d/init.d/xend
Comment 3 Mark McLoughlin 2007-03-30 10:06:07 EDT
Thanks for the report and patch, marking as a dup of bug #234597 which has a
similar patch but also does this on restart.

*** This bug has been marked as a duplicate of 234597 ***

Note You need to log in before you can comment on or make changes to this bug.