Bug 217258 - rpm does not work on package file paths containing spaces
rpm does not work on package file paths containing spaces
Status: CLOSED DUPLICATE of bug 250990
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Depends On:
  Show dependency treegraph
Reported: 2006-11-25 20:24 EST by David Monniaux
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-25 07:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Monniaux 2006-11-25 20:24:57 EST
Description of problem:
rpm does not work on package files whose access path contains spaces

Version-Release number of selected component (if applicable):
4.4.2 release 32

How reproducible:

Steps to Reproduce:
1. put Fedora DVD into DVD drive
2. LANG=C rpm -qip /media/FC-6\ x86_64\
Actual results:
error: open of /media/FC-6 failed: No such file or directory
error: open of /media/FC-6 failed: No such file or directory

Probably, incorrect escaping of file names in the scripts causes this.

Expected results:
should have queried the package

Additional info:
Comment 1 Jeff Johnson 2006-11-25 22:23:25 EST
A work around is
    cd /media/FC-6\ x86_64\ DVD/Fedora/RPMS
    rpm -qip alsa-lib-1.0.12-2.fc6.i386.rpm
Comment 2 Jeff Johnson 2006-11-26 14:09:30 EST
Fixed in rpm cvs, should be in rpm-4.4.8-0.4 when built.

Comment 3 Simo Sorce 2007-06-18 19:52:35 EDT
This bug is present in RHEL-5 as well, is this fix going to be in 5.1 ?
Comment 4 Paul Nasrat 2007-06-19 04:47:18 EDT
Quoting or double escaping works:

rpm -qp Some\\\ Stuff/createrepo-0.4.10-1.noarch.rpm 

rpm -qp 'Some\ Stuff/createrepo-0.4.10-1.noarch.rpm' 
Comment 5 Red Hat Bugzilla 2007-08-21 01:30:02 EDT
User pnasrat@redhat.com's account has been closed
Comment 6 Panu Matilainen 2007-08-22 02:29:41 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 7 Panu Matilainen 2007-10-25 07:13:08 EDT
Marking as dupe of 250990, this is not going to get fixed for FC6 at this point

*** This bug has been marked as a duplicate of 250990 ***

Note You need to log in before you can comment on or make changes to this bug.