Bug 217263 - rpmbuild of kernel fails : gpg seg fault
rpmbuild of kernel fails : gpg seg fault
Status: CLOSED DUPLICATE of bug 213974
Product: Fedora
Classification: Fedora
Component: gnupg (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 22:17 EST by Jerry Amundson
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 22:55:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2006-11-25 22:17:23 EST
Description of problem:
+ for i in '`cat modnames`'
+ 
sh ./scripts/modsign/modsign.sh /var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849PAE/kernel/fs/autofs/autofs.ko 
Red
./scripts/modsign/modsign.sh: line 46: 25490 Segmentation fault      
gpg --no-greeting $KEYFLAGS -b $module.out
error: Bad exit status from /var/tmp/rpm-tmp.5942 (%build)
    Bad exit status from /var/tmp/rpm-tmp.5942 (%build)


Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2849.fc6.src.rpm

How reproducible:
Always.

Steps to Reproduce:
1. rpmbuild -bb --target i686 ../SPECS/kernel-2.6.spec
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jerry Amundson 2006-11-26 11:51:31 EST
Sorry. I'm building under xen and had renamed /lib/tls.
Comment 2 Jerry Amundson 2006-11-27 10:58:45 EST
I am still seeing this, though on different modules each time...

+ for i in '`cat modnames`'
+ sh ./scripts/modsign/modsign.sh
/var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849/kernel/sound/pci/echoaudio/snd-darla24.ko
Red
gpg: WARNING: unsafe permissions on homedir `..'
+ mv -f
/var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849/kernel/sound/pci/echoaudio/snd-darla24.ko.signed
/var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849/kernel/sound/pci/echoaudio/snd-darla24.ko
+ for i in '`cat modnames`'
+ sh ./scripts/modsign/modsign.sh
/var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849/kernel/sound/pci/echoaudio/snd-echo3g.ko
Red
./scripts/modsign/modsign.sh: line 46:  3687 Segmentation fault      gpg
--no-greeting $KEYFLAGS -b $module.out
error: Bad exit status from /var/tmp/rpm-tmp.61454 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.61454 (%build)

Subsequent runs manually succeed with only a warning...
gpg --no-greeting --no-default-keyring --secret-keyring ../kernel.sec --keyring
../kernel.pub --default-key Red -b
/var/tmp/kernel-2.6.18-1.2849-root/lib/modules/2.6.18-1.2849/kernel/sound/pci/echoaudio/snd-indigo.ko.out
gpg: can't create `/root/.gnupg/random_seed': No such file or directory
Comment 3 Rolf Fokkens 2006-12-10 16:10:24 EST
Same here, both when running kernel-2.6.18-1.2849.fc6 and 2.6.18-1.2849.fc6xen.
gnupg = gnupg-1.4.6-2

Sometimes however I'm lucky and the kernel builds. Mostly however the build
fails as only one of the many gpg calls failing is enough.
Comment 4 David Shaw 2006-12-13 22:36:01 EST
This seems to be a dupe of bug 213974
Comment 5 Dave Jones 2006-12-18 22:55:22 EST

*** This bug has been marked as a duplicate of 213974 ***

Note You need to log in before you can comment on or make changes to this bug.