Bug 217264 - png files no longer recognized after update to libpng10.i386 1.0.21-1.fc6
png files no longer recognized after update to libpng10.i386 1.0.21-1.fc6
Product: Fedora
Classification: Fedora
Component: libpng10 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-11-25 22:31 EST by thorjansen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-27 01:27:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description thorjansen 2006-11-25 22:31:53 EST
Description of problem:

After updating my system today via yum, with libpng10 on the list, I had to
reboot to kickstart a flaky sound card, and when the system entered runlevel 5,
the Bluecurve login screen was no longer recognized ("png is not a recognized
format" was the message, I believe). I got the bare-bones login window instead.

After logging in, all png icons on the desktop and in the gnome panels
(including menus) are gone, replaced by nothing (no icon, just grey space), or a
large red "x").

When I tried to change the desktop theme, most of the installed themes (the ones
using png elements) no longer work (same error). However, the desktop and panel
icons that weren't displaying properly changed from the red "x" to the generic
gnome footprint icon.

When trying to change desktop or panel icons (right click, then Properties), all
the png's in /usr/share/pixmaps are not seen in the available icons (though they
are still in the directory if you check with a terminal window).

Version-Release number of selected component (if applicable):

libpng10.i386 1.0.21-1.fc6

How reproducible:

Every time without fail.

Steps to Reproduce:

Just run startx if in runlevel 3, or boot to runlevel 5. I assume this is the
same for other levels except 0 and 6, of course. 

Actual results:

See description above.

Expected results:

The ability to see the normal png's on the desktop, menus and gnome panels.

Additional info:

One thing I noticed was that /usr and /usr/share/pixmaps permissions were
changed (no write permission for user, group or all). This was not the case
prior to update. Adding write for user (chmod u+w) on these diretories had no

Also, my wife keeps jpg's on her desktop, with gnome displaying smaller versions
of the photos. Some of these small versions displayed okay, but some would not
display at all, reverting to a generic icon instead.
Comment 1 Paul Howarth 2006-11-26 06:47:49 EST
I don't know what's causing this but it shouldn't be libpng10 since that's only
present to support legacy applications built against ancient libpng versions;
the GNOME and KDE desktops will be built against the modern libpng package and
will use that to handle display of PNG files.

You might try "yum remove libpng10" to see if there is anything on your system
that actually still requires libpng10 (if yum wants to remove some application
you use, just reply "n" when prompted to confirm the removal).

It's also worth checking that your libpng package is OK, using "rpm -V libpng"
(this should produce no output if everything is OK).

Another useful check would be to try "package-cleanup --problems" to report on
any dependency issues in your system's RPM database; the "package-cleanup"
program is part of the "yum-utils" package.
Comment 2 thorjansen 2006-11-27 01:27:14 EST
Thanks for the pointers. It did end up being a munged libpng/gdm problem, which
was easily fixed by reinstalling the proper update packages.

Note You need to log in before you can comment on or make changes to this bug.