Bug 217291 - FC6 does not recognize FC4 software RAID (upgrade fails)
FC6 does not recognize FC4 software RAID (upgrade fails)
Status: CLOSED DUPLICATE of bug 409931
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-26 11:52 EST by Emil Volcheck
Modified: 2008-04-24 10:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Emil Volcheck 2006-11-26 11:52:46 EST
Description of problem:
FC6 anaconda does not correctly recognize mirrored (RAID0) partitions
constructed using software RAID under FC4.

Version-Release number of selected component (if applicable):


How reproducible:
This arises during installation from the FC6 DVD, and I can reproduce it.

Steps to Reproduce:
1. Boot from FC6 DVD and make usual selections
2. 
3.
  
Actual results:
Anaconda does not find the Linux installation.
Software RAID partition /dev/md0 is not recognized.
Only one side of the mirrored partition is perceived as software RAID
while the other side is perceived as free space.

Expected results:
Proper upgrade.

Additional info:

There was no unusual behavior during installation: ohci1394 and
ata_piix drivers loaded, media check OK, video card found, language
and keyboard selected.

The next page did not offer an upgrade option.  It read
"Installation requires partitioning..."  The pull-down menu on that
page presented the option "Remove linux partitions..."  Further
down, "Select drives to use for this installation."  One selection
was selected and grayed out:

mapper/isw_ddgigcdffi_RAID_Volume1  228942 MB  .

There was no mention of /dev/md0.  Under FC4, I partitioned the drive
to have a boot partition as ext3, swap space, and two partitions of
identical size that were combined to form one mirrored RAID device /dev/md0.
I have never seen /dev/mapper before with FC4.

To get more information, I selected Custom Layout and continued.

I got a dialogue box telling me "/dev/mapper/isw_ddgigcdffi_RAID_Volume1p3
has a partition of type 0x82 (Linux swap) but does not appear to be
formatted as a Linux swap partition.  Would you like to format this
partition as a swap partition?"  I answered "no" and continued.

The next page displayed the partition table.

At the top was the partition map.

Drive /dev/mapper/isw_ddgigcdffi_RAID_Volume1 (228942 MB) Model: Linux device-mapper

The first part in the map (horizontal bar) was labelled
"mapper/isw_ddgigcdffi_RAID_Volume1" for 118276 MB.
Second was a thin space (illegible, presumably swap).
Third was free space for 114470 MB.

The detailed description under "Hard Drives" read as follows.

Hard Drives                                  type   size     start     end

/dev/mapper/isw_ddgigcdffi_RAID_Volume1

 /dev/mapper/isw_ddgigcdffi_RAID_Volume1p1   ext3    102         1      13

 /dev/mapper/isw_ddgigcdffi_RAID_Volume1p2 software 112377      14   14339
                                             RAID                              
           
 /dev/mapper/isw_ddgigcdffi_RAID_Volume1p3   swap    1992     14340  14593

 free                                        free  114471     14594  29186


This is related to a problem with FC5.  FC5 did not recognize the
RAID partitions nor /dev/md0 at all.  This bug may be related to
#186312, #192542, and #186182.
Comment 1 Peter Jones 2006-11-30 15:28:05 EST
Does it work if you boot the installer with "nodmraid" on the command line?
Comment 2 Emil Volcheck 2006-12-02 00:54:45 EST
Yes!  When I entered "linux nodmraid", anaconda recognized FC4 on my
/dev/md0 and then the upgrade went smoothly.  Thank you for suggesting this.
Is this something that can be fixed?  Or will I always have to specify
nodmraid in future upgrades?
Comment 3 Peter Jones 2007-07-09 12:30:28 EDT
This means your disks have RAID metadata from the BIOS on them.  It's probably
best to go into the RAID BIOS and remove the raidsets.
Comment 4 Bug Zapper 2008-04-04 00:57:20 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Emil Volcheck 2008-04-04 01:17:04 EDT
This problem still persists in Fedora 7, which is what I am presently
running.  I used "nodmraid" and that worked, so it's the same fix as
for Fedora 6, so I guess it's the same problem.  As bugs go, this
is serious in the sense that it completely blocks an upgrade, but
not so serious in that there is an easy work-around.

By the way, the comment from Peter Jones didn't make sense to me
as I have no "RAID BIOS".  The RAID is Linux software RAID, so
I don't see how there could be a separate BIOS.  Maybe I'm just
missing something.
Comment 6 Dave Jones 2008-04-04 13:03:19 EDT
so before linux boots, there's no screen that appears showing the disks in your
raid set, with something like a 'press f10 to configure' (or similar wording?)

what controller type are these disks plugged into ?
Comment 7 Joel Andres Granados 2008-04-24 10:06:38 EDT
There is a bug where the dmraid stuff just blocks.  This bug has not been solved
yet and we are still working to fix it.   However there is a work around.  If
you use nodmraid, the installer will ignore/skip the dmraid stuff allowing the
install to finish.  This is a workaround and does not fix the problem.
There is a long list of bugs that are filed against this problem.  This bug is
one of them.  We have decided to close all the related nodmraid bugs and leave
just one open that will represent all of the others.  So this bug will be duped
for this reason.

*** This bug has been marked as a duplicate of 409931 ***

Note You need to log in before you can comment on or make changes to this bug.