This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 217293 - security=ads broken, update to 3.0.23d
security=ads broken, update to 3.0.23d
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks: 218774
  Show dependency treegraph
 
Reported: 2006-11-26 12:13 EST by Rudi Chiarito
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.0.24-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-02 13:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudi Chiarito 2006-11-26 12:13:04 EST
Description of problem:
SPNEGO will fail when using a 3.0.23c server in an AD domain. The bug is known
and fixed in 3.0.23d:

https://bugzilla.samba.org/show_bug.cgi?id=4095

I can confirm that applying the patch from that report solves the problem. An
update to 3.0.23d might still be preferrable, because it fixes several bugs more
as well.

Version-Release number of selected component (if applicable):
3.0.23c-2
Comment 1 Dmitry Butskoy 2006-12-08 07:59:32 EST
Please, update for FC5 too.
Comment 2 Andrew Rechenberg 2006-12-18 14:30:05 EST
ADS security still seems broken on FC6 even with the patch from Samba Bugzilla
4095.  I've applied the patch and rebuild the RPM, but users still can't access
their home directory on a Samba server from a Windows XP SP2 client.  They
receive an access denied error.

I don't see 3.0.23d in Rawhide either (same 3.0.23c).

Any updates on this bug?
Comment 3 Colin Simpson 2007-01-22 13:02:46 EST
Any progress on this bug, I have the same problem and 3.0.23d seems to fix it
but no 64 bit version in RPM on the upstream. Yet 3.0.23d isn't in testing or
Rawhide. I'd have thought this would be quite a high priority bug to fix.
Comment 4 Dmitry Butskoy 2007-02-16 09:07:34 EST
It seems to be fixed for me in the latest updated samba 3.0.24
Comment 5 Colin Simpson 2007-02-16 09:42:41 EST
Yup, fixed for me with the 3.0.24 update.
Comment 6 Colin Simpson 2007-05-02 18:01:05 EDT
I haven't had a chance to fully test this, I may have something wrong in my
setup, but is this also broken in RH EL 5? Given that it ships with samba-3.0.23c-2?
Comment 7 Colin Simpson 2007-06-01 08:39:50 EDT
This looks broken on RH EL 5. We had to install the latest FC6 Samba RPMS to
allow this to work.

Note You need to log in before you can comment on or make changes to this bug.