Bug 21732 - Windows do not open where expected
Windows do not open where expected
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 03:45 EST by Mike A. Harris
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-07 22:19:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2000-12-05 03:45:33 EST
Sawfish and sawmill in ALL versions of RHL do not consistently
open new windos in a sane manner.  For example, using Netscape
or Mozilla, or other apps that run full screen windowed, which
can open a "new window" that is the same size as the existing one,
will not open the new window in the exact same location as the
existing window.

A bit more explanation: Run netscape, maximize it, and bring up
any website with numerous links - Slashdot for example.

Now, right click on a link, and choose "open link in new window"
(or middleclick).  The new window will open maximized like the
original netscape window was.  Now do it again, with another link,
or even the exact same one. A new window will open, etc..

Eventually the new window will not open in the right spot.  Instead,
it will be sized correctly the same as previous windows, but it will
be placed anywhere from 1/4 to 1/2 an nch down the screen overtop the
gnome panel requiring the user drag it back to the normal "maximized"
position.  About 1 in 4 or 1 in 5 windows opens up funny like this
ALL the time, indicating it might be some off-by-one error in the
window placement code or something.  Anyway it only seems to happen
with saw{fish,mill} WM's in GNOME.  It ocurrs in Red Hat 6.2 and 7.0
both with stock gnome, and helix gnome.  I'm using stock gnome right
now.  It is really irritating constantly having to re-place windows
that should "just open" in the right spot.  I considered it being
a window placement config item, but no matter how the options are
set it randomly places every 4th window or so and then places 3
correctly.  It is 100% reproduceable.
Comment 1 Havoc Pennington 2000-12-05 10:56:54 EST
This annoys me too, I see it a lot. Will ask the author of Sawfish about it.
Comment 2 Need Real Name 2000-12-05 13:49:04 EST
I think this bug was fixed in the latest version (0.34) (there was a problem
with one of the smart-placement calculations). I definitely can't reproduce this
problem now
Comment 4 Mike A. Harris 2001-04-12 08:21:51 EDT
Drat.  Sorry for not responding earlier HP.  The bug still exists
in our latest release as of today.  This bug is incredibly annoying.
I tried the packages above and thought that I had updated the bug report
and now find I did not.  ;o(

Since sawfish is the default WM, I think this bug should be fixed in the
next errata as it makes the wm behave so irrationally.  I have watched
many others get irritated by this bug as well.  I think I'm going to just
switch to E for now..  If you find a fix though, I'm ready to test it out
for you (and then delete E once again..)  ;o)

I'm currently using sawfish-0.36-7

Thanks.
Comment 5 Havoc Pennington 2001-07-12 17:44:50 EDT
Filed upstream as http://bugzilla.eazel.com/show_bug.cgi?id=8415

Closing on Red Hat level.
Comment 6 Havoc Pennington 2001-08-24 00:09:25 EDT
The upstream bug has been marked fixed, for anyone who's curious
Comment 7 Jose Manuel Rios Fonseca 2001-12-03 07:15:33 EST
According to the sawfish mailing list  (
http://lists.eazel.com/pipermail/sawfish/2001-November/002009.html ) this bug
has been corrected in the 1.0.1 version (
http://lists.eazel.com/pipermail/sawfish-announce/2001-October/000014.html ) .

I have a registered version of RHL 7.1 at the office and a downloaded version of
RHL 7.2 in my laptop and in both I get annoyed by this bug.

I agree with Mike Harris and think that now should be a good time to make an
updated version of sawfish.
Comment 8 Mike A. Harris 2001-12-03 16:01:01 EST
This bug is the sole reason for me switching to KDE.  All I'm told
by people is that it is fixed, or that it is not reproduceable, when
it is reproduceable on every install I've ever seen, with both
sawfish/sawmill, and enlightenment.  And people who I've talked to
that do use GNOME that say they can't reproduce it (friends), I have
went to their machines and reproduced it in seconds to know it is a
problem, just not one they notice or not one they notice in their
usage patterns.

So, in my case it is CLOSED->USEKDEITHASNONBUGGYWINDOWMANAGER
Comment 9 Havoc Pennington 2001-12-03 16:27:30 EST
Mike, stop ranting. I don't care what desktop you use, really. ;-)
It is not a motivational factor for me.

We'll upgrade sawfish in the next release, if it's fixed then excellent.
Comment 10 Mike A. Harris 2001-12-03 17:12:41 EST
Sorry.. I didn't mean for it to sound like a rant Havoc. ;o)
And I wasn't implying that you should fix it..  or I'd reopen it.  ;o)

Just expanding on my previous thoughts, and trying to inject
some humor.  I guess I missed the smileys.  ;o)

Sorry for giving wrong inflection there.

Please save me from KDE!  C++ is evil!  ;oP
Comment 11 Federico Mena-Quintero 2001-12-17 20:49:49 EST
Please try it again with the latest version from CVS.  I've been fixing some
bugs that are related to window placement.

If you still experience problems, could you please tell me which placement mode
you are using (e.g. top-left, best-fit, etc.) and how to reproduce the problem?

Also, it is better if you file sawfish bugs in bugzilla.gnome.org -- I'll grab
them sooner if they appear there.
Comment 12 Mike A. Harris 2002-02-07 21:29:37 EST
I just installed a fresh 7.2 on my test box and thought I'd give GNOME a whirl
again.  Very nice looking stuff mostly.  Much faster than KDE, especially on
a 300Mhz machine.

Sawfish bug still present in 0.38-11 though. Let me know anything I should
try in order to help find a fix, including upgrading to test code, etc.

Comment 13 Havoc Pennington 2002-02-07 21:40:05 EST
You could try Sawfish 1.0.1 at ftp://people.redhat.com/hp/gnomehide/

Bug is still wontfix though, I do not code Lisp, and do not plan to learn. ;-)
Comment 14 Mike A. Harris 2002-02-07 22:15:47 EST
Ok, update:

1) I am a moron
2) I didn't read what federico said above prior to reopening bug after
   finding problem still present.
3) I am a moron
4) I went on irc.gnome.org and also a few other places, and got convinced to
   try newer cvs code.  then teg told me to try gnomehide.
5) I am a moron.
6) I upgraded to gnomehide sawfish, librep and rep-gtk-* and the problem
   is now gone.  sawfish works as it should.
7) I am a moron.

Sorry for wasting your time reopeing this without doing my homework
_first_.  I assumed 7.2 had the latest code.  Now my excuse list for
not using GNOME is empty.  Hmm.  Darth-bero's not going to like this,
he's losing his grip.

Closing fixed in sawfish 1.0.1 in rawhide.
Comment 15 Mike A. Harris 2002-02-07 22:19:27 EST
LOL, our updates collided.  Hehe.

Lisp is evil.  I don't blame you for not wanting to learn lisp.  I
wouldn't either.  FIxing bug resolution to rawhide.

Note You need to log in before you can comment on or make changes to this bug.