Bug 217327 - Inserting audio CD on RHEL 5 Client Beta 2 causes it to crash
Inserting audio CD on RHEL 5 Client Beta 2 causes it to crash
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-26 22:09 EST by Nik Lam
Modified: 2013-01-10 16:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 11:23:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output for optiplex 745 (24.24 KB, text/plain)
2006-11-29 19:50 EST, Nik Lam
no flags Details
capture of gdb session on totem /dev/scd0 (4.00 KB, text/plain)
2006-12-06 19:37 EST, Nik Lam
no flags Details

  None (edit)
Description Nik Lam 2006-11-26 22:09:50 EST
Description of problem:

A basic install of RHEL5 client beta 2 with the office productivity and
developer set of software.  The PC is a brand new Dell optiplex 745 with a core
2 duo processor with VT switched on in the bios (the rest of the bios settings
are at their default values).

As soon as I insert an (original pressed) audio CD, totem loads - it looks like
it's trying to get CDDB data or something - it shows all the track numbers and
looks like it's about to start playing the first track, but then the bottom few
centimetres of the screen goes blank, then everything goes blank. The mouse
pointer comes and goes a few times on the middle of the blank screen, but
evenutally goes for ever and I have to do a hard reset of the PC.




Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Boot PC
2. Log in with standard user privs
3. Wait for login to finish.
4. Insert standard audio cd.
  
Actual results:

PC crashes.

Expected results:

Audio CD player software willl launch, download CDDB data and begin playing CD.


Additional info:

We do not have direct access to port 80 outside the campus, it must go through a
web proxy cache. I've not configured this - I don't know if that is having any
influence on the problem.
Comment 2 Bastien Nocera 2006-11-27 05:31:19 EST
Totem doesn't check CDDB, or Musicbrainz anymore, so it must be something different.

Could you please gather a backtrace of the crash following the instructions at
http://fedoraproject.org/wiki/StackTraces
Comment 3 Matthias Clasen 2006-11-29 08:48:41 EST
I couldn't reproduce the crash here on a beta2 system - totem started playing
just fine. It didn't display song titles, though.
Comment 4 Nik Lam 2006-11-29 19:50:08 EST
Created attachment 142456 [details]
dmesg output for optiplex 745

The thing that I notice about the boot up process on this system is that it
gets stuck on the ata3 and ata4 "probes" and eventually times out.
Comment 5 Nik Lam 2006-11-29 19:51:39 EST
I've not acquired a backtrace of the crash (I can't work out how to do it based
on the documentation in the wiki and I don't have time to delve into it at the
moment).  I did however try a new install on an identical, brand new Optiplex
745 and got exactly the same result.  I created the attachment of the dmesg in
case there is anything in there which is relevant.
Comment 6 Bastien Nocera 2006-11-30 05:00:09 EST
Without a stack trace, we can't determine where the problem lies. As Matthias
couldn't reproduce the problem on recent versions, I'll close this as obsolete.
Please reopen if you can gather a backtrace (it should be automatic when Totem
crashes, you'd get the bug report tool) with Beta 2 or newer.
Comment 7 Nik Lam 2006-11-30 19:57:26 EST
When Totem crashes, the operating system crashes, so unless something is written
to a file somewhere, any debug info will be gone.
Comment 8 Alexander Larsson 2006-12-01 04:02:34 EST
The operating system crashes?
Are you saying the kernel locks up? That sounds more like a hardware or a driver
issue.
Comment 9 Alexander Larsson 2006-12-01 04:13:04 EST
Does other cd player apps have the same issue? e.g. gnome-cd, or the kde cd
player. Does cd ripping work (cdparanioa, sound-juicer)?
Comment 10 Nik Lam 2006-12-03 22:50:47 EST
The problem occurs only if totem is automatically launched when the CD is
inserted and the CD icon appears on the desktop. If I launch totem first, then
insert the CD, an icon for the disc appears on the desktop, with the name "Audio
Disc" and I get a popup saying

Totem could not play 'cdda:///dev/scd0'.
No URI handler implemented for "cdda".

Totem then refuses to play the CD.  The "Movie" menu has the following items:

Open...
Open Location...
Play Disc 'Audio Disc'
-----------
Eject
-----------
1. scd0
-----------
Play/Pause
-----------
Quit

However, "Play Disc 'Audio Disc'" is greyed out, and so is "Eject".  If i select
"1. scd0" or "Play/Pause, then I get the popup message again.

I can't get Totem to play the CD.  Once the disc is mounted on the desktop
though, I can quit Totem and I can launch the CD Player from the "Sound & Video"
menu and it will download track names from CDDB and play them without a hitch.

I can also do the same using rythmbox, although it does not download track names.

I can also extract the tracks using sound juicer, although like rythmbox, it
doesn't download track names.

Similarly, if I start cd-player before inserting the CD, when I insert it, CD
player displays track names, and I can start playing the tracks. However, the
moment I press the stop button on CD player, I see the CD icon on the desktop,
and Totem launches, tries to play the CD then the system crashes.
Comment 11 Bastien Nocera 2006-12-04 06:49:45 EST
What's the actual command that was launched?
Please check in the output of "ps aux" which command was used to launch totem.

I tried to reproduce the problem, and wasn't able to.

Is the CD you're inserting a CD Extra, or one with a data track?
Comment 12 Bastien Nocera 2006-12-04 09:20:41 EST
totem cdda:///dev/hdc doesn't work.

CDDA used to be very special-cased in Totem, and I guess we need to bring this
back. Oh, I wish for Rhythmbox was able to play Audio CDs from the CLI.

Matthias, could you devel ack+ please?
Comment 13 Nik Lam 2006-12-04 17:47:17 EST
As I inserted the CD, I kept a terminal window open and continually issued

ps auxw | grep totem

The line that showed up, just before the crash showed the command as

totem /dev/scd0


The main CD I've been using is a plain pressed audio CD.

Comment 14 Bastien Nocera 2006-12-06 05:45:11 EST
"totem /dev/scd0" works just fine in my tests.

I've file http://bugzilla.gnome.org/show_bug.cgi?id=382955 to track the "totem
cdda:///dev/hdc" doesn't work.

n.lam, could you please try to gather a backtrace of the crash using gdb, by
launching "totem /dev/scd0" by hand?

As none of us can reproduce the crasher you're seeing, we won't be able to fix
it without getting a backtrace of the crash.
Comment 15 Nik Lam 2006-12-06 19:37:41 EST
Created attachment 143011 [details]
capture of gdb session on totem /dev/scd0

Through the "Removable Drives and Media Preferences", I've unchecked the "Play
audio CD discs when inserted" option, so I can now insert audio CDs without
totem launching (if no other application is accessing the CD). The CD still
gets mounted, and shows up on the desktop.

From a terminal window I've initiated totem via gdb, then run it with /dev/scd0
as the argument. Unfortunately the script output didn't get written to file
before the OS crashes, though I don't know if that output will be useful to
anyone anyway.	But if I can be provided with information on some other way of
running totem so that I get a core dump or something that is recoverable after
the crash, then I'll be able to send something to you.

Let me know if any of you can give me any pointers on what to do.
Comment 16 Bastien Nocera 2006-12-07 12:40:10 EST
Reassigning to the kernel, as it seems that the whole machine is crashing, Totem
is just the trigger.
Comment 17 Nik Lam 2006-12-08 06:20:07 EST
Yes the whole machine is crashing. X windows almost totally disappears. The only
thing left is the mouse pointer with the little blue swirl around it, and this
flashes on and off every 5 seconds or so - but the pattern is not regular. While
in this state, the mouse pointer responds to mouse movement, but keyboard
combinations like ctrl+alt+backspace or ctrl+alt+delete or ctrl+alt+F1 don't do
anything. After some time, maybe a couple of minutes, this behaviour stops, and
I'm left with a fully blank screen, and apparently no input being responded to,
so I just reboot.

I'm not sure if this has any relation to the extremely slow boot that I
experience on these PCs. Please see the first dmesg attachment and let me know
if you think it needs to be reported as a separate bug - basically it needs to
go trhough two 30 second timeouts during boot up.
Comment 18 Jay Turner 2006-12-13 21:33:56 EST
Are we able to reproduce this on any other systems?  Without more details, I
can't QE ack.
Comment 19 Matthias Clasen 2006-12-14 00:59:23 EST
Bastian, when changing component, you should reassign to the component owner.
Otherwise, the bug falls off everyones radar.
Comment 20 Peter Martuccelli 2006-12-15 13:59:52 EST
The SATA timeouts are a different problem and are not causing this issue, we are
working on resolving the slow boot time for R5 GA.

John - We need to reproduce this problem in house as I am not sure what state
the system is left in without a backtrace.

No Dev ACK until I get a backtrace to review.
Comment 24 Peter Martuccelli 2006-12-19 11:23:02 EST
Dell Optiplex systems are not certified on RHEL.  Dell support will need to be
contacted with any problems.  

Closing this issue out as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.