This bug has been migrated to another issue tracking site. It has been closed here and may no longer be being monitored.

If you would like to get updates for this issue, or to participate in it, you may do so at Red Hat Issue Tracker .
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2173279 - Image Builder fails when vfat is blacklisted by some standards
Summary: Image Builder fails when vfat is blacklisted by some standards
Keywords:
Status: CLOSED MIGRATED
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: osbuild
Version: 8.7
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Image Builder team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-02-25 10:29 UTC by Christophe Besson
Modified: 2023-09-18 13:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-18 13:36:03 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker   RHEL-4637 0 None Migrated None 2023-09-18 13:35:59 UTC
Red Hat Issue Tracker RHELPLAN-149881 0 None None None 2023-02-25 10:32:16 UTC
Red Hat Knowledge Base (Solution) 6999729 0 None None None 2023-02-25 10:29:48 UTC

Description Christophe Besson 2023-02-25 10:29:48 UTC
Description of problem:
The worker fails with a python traceback with a very limited track to investigate why it failed. In short we only know this:
osbuild.host.RemoteError: CalledProcessError: Command '['mount', '-t', 'vfat', '--source', '/run/osbuild/osbuild-dev-1c3snfrw/loop0', '--target', '/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi']' returned non-zero exit status 32.

Version-Release number of selected component (if applicable):
osbuild-composer-62-3.el8_7.x86_64
osbuild-composer-worker-62-3.el8_7.x86_64
osbuild-65-1.el8.noarch

How reproducible:
Always

Steps to Reproduce:
1. Implement CIS security standards (https://www.cisecurity.org/benchmark/red_hat_linux)

# grep vfat /etc/modprobe.d/cis.conf 
install vfat /bin/true

2. Try to create a VMDK image

Actual results:
Feb 23 13:41:34 localhost osbuild-worker[1878946]: time="2023-02-23T13:41:34-05:00" level=info msg="Running job 'af7e404b-8be1-4136-b9ff-8e1eb757ecb8' (osbuild)\n"
Feb 23 14:00:38 localhost platform-python[3853757]: detected unhandled Python exception in '/usr/bin/osbuild'
Feb 23 14:00:38 localhost osbuild-worker[3853757]: Traceback (most recent call last):
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/bin/osbuild", line 11, in <module>
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     load_entry_point('osbuild==65', 'console_scripts', 'osbuild')()
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/main_cli.py", line 169, in osbuild_cli
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     stage_timeout=stage_timeout
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/pipeline.py", line 452, in build
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     res = pl.run(store, monitor, libdir, stage_timeout)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/pipeline.py", line 363, in run
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     stage_timeout)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/pipeline.py", line 337, in build_stages
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     stage_timeout)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/pipeline.py", line 221, in run
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     data = mntmgr.mount(mount)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/mounts.py", line 77, in mount
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     path = client.call("mount", args)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/host.py", line 348, in call
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     ret, _ = self.call_with_fds(method, args)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/host.py", line 384, in call_with_fds
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     raise error
Feb 23 14:00:38 localhost osbuild-worker[3853757]: osbuild.host.RemoteError: CalledProcessError: Command '['mount', '-t', 'vfat', '--source', '/run/osbuild/osbuild-dev-1c3snfrw/loop0', '--target', '/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi']' returned non-zero exit status 32.
Feb 23 14:00:38 localhost osbuild-worker[3853757]:    File "/usr/lib/python3.6/site-packages/osbuild/host.py", line 268, in serve
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     reply, reply_fds = self._handle_message(msg, fds)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/host.py", line 301, in _handle_message
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     ret, fds = self.dispatch(name, args, fds)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/mounts.py", line 110, in dispatch
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     r = self.mount(args)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib/python3.6/site-packages/osbuild/mounts.py", line 149, in mount
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     check=True)
Feb 23 14:00:38 localhost osbuild-worker[3853757]:   File "/usr/lib64/python3.6/subprocess.py", line 438, in run
Feb 23 14:00:38 localhost osbuild-worker[3853757]:     output=stdout, stderr=stderr)
Feb 23 14:00:38 localhost osbuild-worker[1878946]: time="2023-02-23T14:00:38-05:00" level=error msg="osbuild job failed: osbuild build failed" jobId=af7e404b-8be1-4136-b9ff-8e1eb757ecb8
Feb 23 14:00:38 localhost osbuild-worker[1878946]: time="2023-02-23T14:00:38-05:00" level=warning msg="Job 'af7e404b-8be1-4136-b9ff-8e1eb757ecb8' (osbuild) failed: error decoding osbuild output: unexpected end of JSON input\nthe raw output:\n"

Expected results:
The compose log is not empty and/or the fatal error causing the issue is reported somehow: "/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi: unknown filesystem type 'vfat'."

Additional info:
3892727 14:00:10.625710 execve("/usr/bin/mount", ["mount", "-t", "vfat", "--source", "/run/osbuild/osbuild-dev-1c3snfrw/loop0", "--target", "/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi"], ["LANG=en_US.UTF-8", "PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin", "INVOCATION_ID=66f1bd1e8cd041659d889f15d8c947e5", "JOURNAL_STREAM=9:46845814", "CACHE_DIRECTORY=/var/cache/osbuild-worker", "PYTHONPATH=/usr/lib/python3.6/site-packages", "PYTHONUNBUFFERED=1"] <unfinished ...>
 :
3892727 14:00:10.640515 lstat("/run/osbuild/osbuild-dev-1c3snfrw/loop0", {st_dev=makedev(0, 0x30), st_ino=52376612, st_mode=S_IFBLK|0600, st_nlink=1, st_uid=0, st_gid=0, st_blksize=4096, st_blocks=0, st_rdev=makedev(0x7, 0), st_atime=1677178809 /* 2023-02-23T14:00:09.086059538-0500 */, st_atime_nsec=86059538, st_mtime=1677178809 /* 2023-02-23T14:00:09.086059538-0500 */, st_mtime_nsec=86059538, st_ctime=1677178809 /* 2023-02-23T14:00:09.086059538-0500 */, st_ctime_nsec=86059538}) = 0 <0.000096>
 ;
3892727 14:00:10.641429 lstat("/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi", {st_dev=makedev(0x7, 0x1), st_ino=2097280, st_mode=S_IFDIR|0755, st_nlink=2, st_uid=0, st_gid=0, st_blksize=4096, st_blocks=0, st_size=6, st_atime=1677178810 /* 2023-02-23T14:00:10.622097056-0500 */, st_atime_nsec=622097056, st_mtime=1677178810 /* 2023-02-23T14:00:10.622097056-0500 */, st_mtime_nsec=622097056, st_ctime=1677178810 /* 2023-02-23T14:00:10.622097056-0500 */, st_ctime_nsec=622097056}) = 0 <0.000015>
3892727 14:00:10.641521 stat("/sbin/mount.vfat", 0x7ffe060ce850) = -1 ENOENT (No such file or directory) <0.000022>
 :
3892727 14:00:10.642403 mount("/run/osbuild/osbuild-dev-1c3snfrw/loop0", "/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi", "vfat", MS_MGC_VAL, NULL) = -1 ENODEV (No such device) <0.030853>
 :
3892727 14:00:10.673777 write(2<pipe:[52375186]>, "mount: ", 7) = 7 <0.000021>
3892727 14:00:10.673854 write(2<pipe:[52375186]>, "/var/cache/osbuild-worker/osbuild-store/tmp/buildroot-tmp-61r3d8fr/mounts/boot/efi: unknown filesystem type 'vfat'.", 115) = 115 <0.000014>
 :
3892727 14:00:10.674144 exit_group(32)  = ?
3892727 14:00:10.674371 +++ exited with 32 +++

Comment 1 RHEL Program Management 2023-09-18 13:34:32 UTC
Issue migration from Bugzilla to Jira is in process at this time. This will be the last message in Jira copied from the Bugzilla bug.

Comment 2 RHEL Program Management 2023-09-18 13:36:03 UTC
This BZ has been automatically migrated to the issues.redhat.com Red Hat Issue Tracker. All future work related to this report will be managed there.

Due to differences in account names between systems, some fields were not replicated.  Be sure to add yourself to Jira issue's "Watchers" field to continue receiving updates and add others to the "Need Info From" field to continue requesting information.

To find the migrated issue, look in the "Links" section for a direct link to the new issue location. The issue key will have an icon of 2 footprints next to it, and begin with "RHEL-" followed by an integer.  You can also find this issue by visiting https://issues.redhat.com/issues/?jql= and searching the "Bugzilla Bug" field for this BZ's number, e.g. a search like:

"Bugzilla Bug" = 1234567

In the event you have trouble locating or viewing this issue, you can file an issue by sending mail to rh-issues. You can also visit https://access.redhat.com/articles/7032570 for general account information.


Note You need to log in before you can comment on or make changes to this bug.