Bug 217329 - Uncommitted pre-edit buffer moves with mouse click
Uncommitted pre-edit buffer moves with mouse click
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-26 22:21 EST by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 00:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Expected results (41.43 KB, image/png)
2006-11-26 22:21 EST, Jong Bae KO
no flags Details
Actual results (41.46 KB, image/png)
2006-11-26 22:22 EST, Jong Bae KO
no flags Details
The screenshot of the correct rending of given hangul keysquences (364.52 KB, image/png)
2007-01-12 02:44 EST, Ramakrishna Reddy Yekulla
no flags Details
pre edit buffer fine with scim-bridge (41.96 KB, image/png)
2007-01-18 20:57 EST, Ramakrishna Reddy Yekulla
no flags Details

  None (edit)
Description Jong Bae KO 2006-11-26 22:21:17 EST
Description of problem:
In pre-editing state if you click other place, the letter of pre-editing is
moved to clicked place and commited.


Version-Release number of selected component (if applicable):
scim-bridge-0.4.8-1.fc7
gedit-2.15.9-1.fc6

How reproducible:
always

Steps to Reproduce:
1. run oowriter
2. type "eogksalsrnr" <-  대한민국
3. click between 대 and 한


Actual results:
대국한민

Expected results:
대한민국


Additional info:
Comment 1 Jong Bae KO 2006-11-26 22:21:17 EST
Created attachment 142154 [details]
Expected results
Comment 2 Jong Bae KO 2006-11-26 22:22:17 EST
Created attachment 142155 [details]
Actual results
Comment 3 Caolan McNamara 2006-11-28 06:24:53 EST
This is the same as http://qa.openoffice.org/issues/show_bug.cgi?id=67316 and
need to be considered by upstream, i.e. CANTFIX by me.
Comment 4 Caolan McNamara 2006-11-28 06:26:31 EST
damnit, wrong bug. 
Comment 5 Jens Petersen 2006-11-28 19:47:47 EST
Just to note that is does not happen with scim gtkimm and it also
is also reproducible in gedit.
Comment 6 Jens Petersen 2006-12-03 19:01:34 EST
Dairiki-san committed a patch for this in upstream cvs. :)

scim-bridge/client-common scim-bridge-client.c, 1.32,1.33
- Fix the timing issue of the reset_imcontext.
Comment 7 Jong Bae KO 2006-12-21 23:08:31 EST
this bug is included CJK language. :(
Comment 8 Jens Petersen 2007-01-01 19:37:03 EST
Could you try scim-bridge-0.4.9-1.fc7 and see if it is better?
Comment 9 Jong Bae KO 2007-01-04 01:29:59 EST
with scim, It shows right behavior. :)
Comment 10 Jong Bae KO 2007-01-07 23:04:16 EST
Jens,

I tested gedit with scim-bridge-0.4.9-1.fc7. 
It showed right behavior in Hangul now :)
We can close this bug.
Comment 11 Jens Petersen 2007-01-08 00:07:50 EST
Thanks, John.
Comment 12 Ramakrishna Reddy Yekulla 2007-01-12 02:41:18 EST
Environment Setup ::
1. scim-hangul
2. gnome-terminal

Steps to reproduce
For Gedit ::
1. Activate Scim [Ctrl + Space]
2. korean -> Hangul
3. Type in the keysequence :: type "eogksalsrnr" <-  대한민국

For  OpenOffice ::
1. Activate Scim [Ctrl + Space]
2. korean -> Hangul
3. Type in the keysequence :: type "eogksalsrnr" <-  대한민국


Results
This bug is fixed , attached a screenshot for confirmation. resolving it.
Comment 13 Ramakrishna Reddy Yekulla 2007-01-12 02:44:53 EST
Created attachment 145432 [details]
The screenshot of the correct rending of given hangul keysquences
Comment 14 Ramakrishna Reddy Yekulla 2007-01-18 20:57:32 EST
Created attachment 145958 [details]
pre edit buffer fine with scim-bridge

Environment Setup ::
1. scim-hangul
2. gnome-terminal

Steps to reproduce
For Gedit ::
1. Activate Scim [Ctrl + Space]
2. korean -> Hangul
3. Type in the keysequence :: type "eogksalsrnr" <-  대한민국
4. double clicking between 대 한 giving result as in Comment #1

For  OpenOffice ::
1. Activate Scim [Ctrl + Space]
2. korean -> Hangul
3. Type in the keysequence :: type "eogksalsrnr" <-  대한민국
4. Double clicking between 대 한 giving result as in Comment #1

Results
This bug is fixed , attached a screenshot for confirmation. resolving it.
Comment 15 Jong Bae KO 2007-01-21 20:49:03 EST
Hi rreddy,

I am sure it is fiexed on Gedit.
Could you provide versions of scim-hangul & openoffice?
I will double check it, because It wasn't fixed in RHEL5 yet.
Thanks.
Comment 16 Ramakrishna Reddy Yekulla 2007-01-22 09:26:20 EST
Hi jko,

scim-1.4.5-7.fc7
scim-hangul-0.2.2-7.fc6
openoffice.org-writer-2.0.4-5.5.3

regards


Note You need to log in before you can comment on or make changes to this bug.