Bug 217349 - Include lingerd for huge performace gains in webapps
Include lingerd for huge performace gains in webapps
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 06:36 EST by Jan Wildeboer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 07:08:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Wildeboer 2006-11-27 06:36:14 EST
Description of problem:

Feature Request

Version-Release number of selected component (if applicable):

All Apache in RHEL4/5

How reproducible:

Always
Steps to Reproduce:
1. Put dynamic pages up
2. Put apache under stress
3. Wait
  
Actual results:

Lots of processes end up in FIN_WAIT, blocking untill release

Expected results:

Fast release fo apache processes by using lingerd.

Additional info:

I propose to add lingerd as optional component to RHEL. Infos about lingerd:

http://www.iagora.com/about/software/lingerd/

Lingerd is a daemon (service) designed to take over the job of properly closing
network connections from an http server like Apache.

Because of some technical complications in the way TCP/IP and HTTP work, each
Apache process currently wastes a lot of time "lingering" on client connections,
after the page has been generated and sent. Lingerd takes over this job, leaving
the Apache process immediately free to handle a new connection. As a result,
Lingerd makes it possible to serve the same load using considerably fewer Apache
processes. This translates into a reduced load on the server.

Lingerd is particularily useful in Apache webservers that generate dynamic pages
(e.g in conjunction with mod_perl, mod_php or Java/Jakarta/Tomcat).

More importantely, lingerd can only do an effective job if HTTP Keep-Alives are
turned off; since keep-alives are useful for images, the recommended lingerd
setup is to have an Apache/mod_whatever/lingerd server for the dynamic pages,
and a plain Apache (or thttpd or boa) for the images.
Comment 1 Joe Orton 2006-11-27 07:08:13 EST
This is not a feature for httpd it's a whole new package.  I think it would be
useful submission to Extras, maybe you could take that on?

http://fedoraproject.org/wiki/Extras/NewPackageProcess

Note You need to log in before you can comment on or make changes to this bug.