Bug 217365 - French Man-pages from net-tools are in German
French Man-pages from net-tools are in German
Status: CLOSED DUPLICATE of bug 165701
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 10:21 EST by Edouard Bourguignon
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 10:43:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2006-11-27 10:21:31 EST
Description of problem:

French man-pages included in net-tools package are in fact in German

Version-Release number of selected component (if applicable):

<=net-tools-1.60-37.EL4.8

How reproducible:

static

Steps to Reproduce:
1.LANG=fr man arp
2.that's german (Handbuch für Linuxprogrammierer)

Actual results:

man-pages are in German, but they are supposed to be in French (files are in
/usr/share/man/fr)

Expected results:

man-pages should be in French

Additional info:

The problem is located in the .spec of the net-tools packages at lines 135 and
above:

#german
iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/de_DE/arp.8 && mv arp.tmp
man/fr_FR/arp.8
iconv -f iso-8859-1 -t utf-8 -o ethers.tmp man/de_DE/ethers.5 && mv ethers.tmp
man/fr_FR/ethers.5
iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/de_DE/hostname.1 && mv
hostname.tmp man/fr_FR/hostname.1
iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/de_DE/ifconfig.8 && mv
ifconfig.tmp man/fr_FR/ifconfig.8
iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/de_DE/netstat.8 && mv
netstat.tmp man/fr_FR/netstat.8
iconv -f iso-8859-1 -t utf-8 -o plipconfig.tmp man/de_DE/plipconfig.8 && mv
plipconfig.tmp man/fr_FR/plipconfig.8
iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/de_DE/rarp.8 && mv rarp.tmp
man/fr_FR/rarp.8
iconv -f iso-8859-1 -t utf-8 -o route.tmp man/de_DE/route.8 && mv route.tmp
man/fr_FR/route.8
iconv -f iso-8859-1 -t utf-8 -o slattach.tmp man/de_DE/slattach.8 && mv
slattach.tmp man/fr_FR/slattach.8

as you can see, german pages are iconverted and then moved in the wrong path,
overwritting french manpages. Remplacing in this section fr_FR by de_DE works
Comment 1 Edouard Bourguignon 2006-11-27 10:28:17 EST
I already had this problem before, that was supposed to be fixed (bug #172434)
Comment 2 Radek Vokal 2006-11-27 10:43:16 EST
Will be out with 4.5

*** This bug has been marked as a duplicate of 165701 ***

Note You need to log in before you can comment on or make changes to this bug.