Bug 217388 - Xvfb crashes when the client disconnects
Summary: Xvfb crashes when the client disconnects
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-27 17:57 UTC by Jan "Yenya" Kasprzak
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 22:59:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core dump (2.43 MB, application/octet-stream)
2007-02-19 20:29 UTC, Adam Tkac
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9173 None None None Never

Description Jan "Yenya" Kasprzak 2006-11-27 17:57:48 UTC
Description of problem:
I run OpenOffice.org under Xvfb to do some batchmode conversions. When the
last X client disconnects, the Xvfb crashes with SIGSEGV.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xvfb-1.1.1-47.1.fc6.x86_64 (not tested on other archs)

How reproducible:
100%

Steps to Reproduce:
1. Run Xvfb -ac :1 &
2. Run DISPLAY=:1 oowriter & [or any other X client]
3. after few seconds, kill the oowriter
  
Actual results:
after the X client (oowriter) exits, the Xvfb crashes with SIGSEGV

Expected results:
Xvfb should continue

Additional info:
I have found the following mail:
http://lists.freedesktop.org/archives/xorg/2005-April/007657.html
and indeed, adding "-extension Composite" to the Xvfb command line makes the
problem disappear. So the problem is in the Composite extension of the X server.

Comment 1 Adam Tkac 2007-02-19 20:29:27 UTC
Created attachment 148364 [details]
core dump

Also reproducible with xorg-x11-server-Xvfb-1.1.1-47.4.fc6 (arch i386). As is
written in comment #1 when I disable Composite extension all works fine. I've
attached core dump if this could help with solving the problem

Comment 2 Adam Jackson 2007-04-05 20:24:21 UTC
Still happens in rawhide, for some reason.  I thought I'd fixed this...

Comment 3 Adam Jackson 2007-04-09 22:59:53 UTC
Will be fixed in 1.2.99.905-2.fc7


Note You need to log in before you can comment on or make changes to this bug.