Bug 217392 - boot.iso + "linux rescue" drops into python debugger
boot.iso + "linux rescue" drops into python debugger
Status: CLOSED DUPLICATE of bug 217376
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 13:42 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 13:37:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-11-27 13:42:28 EST
Description of problem:

When using the boot.iso in rescue mode, the installer dies with a python error.

Version-Release number of selected component (if applicable): rawhide-20061127


How reproducible: 100%


Steps to Reproduce:
1. Boot boot.iso with "linux rescue"
2. Select NFS ...
  
Actual results:

Running anaconda, the Fedora Core rescue mode - please wait...                 
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 741, in ?
    anaconda.id = instdata.InstallData([], "fd0", anaconda.methodstr, opts.disp)
  File "/usr/lib/anaconda/instdata.py", line 281, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 70, in reset
    self.bootloader = bootloader.getBootloader()
  File "/usr/lib/anaconda/bootloader.py", line 207, in getBootloader
    return booty.getBootloader()
  File "/usr/lib/booty/booty.py", line 37, in getBootloader
    return ia64BootloaderInfo()
  File "/usr/lib/booty/bootloaderInfo.py", line 615, in __init__
    bootloaderInfo.__init__(self)
  File "/usr/lib/booty/bootloaderInfo.py", line 481, in __init__
    self.updateDriveList()
  File "/usr/lib/booty/bootloaderInfo.py", line 445, in updateDriveList
    self.drivelist = self.createDriveList()
  File "/usr/lib/booty/bootloaderInfo.py", line 436, in createDriveList
    drives = isys.cachedDrives.keys()
AttributeError: 'NoneType' object has no attribute 'keys'
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system

Expected results: Should boot into linux rescue mode.
Comment 1 Jeremy Katz 2006-11-28 13:37:49 EST

*** This bug has been marked as a duplicate of 217376 ***

Note You need to log in before you can comment on or make changes to this bug.