Bug 217395 - system-config-printer should update /etc/cups/lpoptions
system-config-printer should update /etc/cups/lpoptions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-11-27 13:53 EST by Stuart Jansen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.45-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 18:54:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Jansen 2006-11-27 13:53:24 EST
Description of problem:
/etc/cups/lpoptions is not updated when system-config-printer is used to select
a new default printer.

Version-Release number of selected component (if applicable):
system-config-printer-0.7.35-1.fc6
cups-1.2.5-2.fc6.8

How reproducible:
Always.

Steps to Reproduce:
1. Add a printer using system-config-printer, make it the default printer.
2. Add a secont printer, make it the default printer.
3. Run lpq, lpoptions, etc. Observe that the first printer is still the default.
4. Examine /etc/cups/printers.conf. Notice that the second printer is listed as
the default printer.
5. Poke at system-config-printer by switching printer1 to default then printer2
back to default. Observe that this did no good.
6. Manually edit /etc/cups/lpoptions. Notice that printer1 is listed as default
despite what system-config-printer and /etc/cups/printers.conf think. Manually
switch to printer2 as default.
7. Run lpq, lpoptions, etc. Observe that printer2 is now the default.
8. Tear our hair, curse at the ceiling. Throw things if necessary.
  
Actual results:
lp*, acroread, etc. choose the wrong default printer

Expected results:
The default specified in system-config-printer should be the default printer in
all applications and with all commands.

Additional info:
Looks like /etc/cups/printers.conf is being updated, but /etc/cups/loptions
isn't being updated.
Comment 1 Tim Waugh 2006-11-27 14:18:44 EST
Ah, I bet this was an update from a previous release of Fedora..

Will need code to fetch /admin/conf/lpoptions and replace 'Default' with 'Dest'
if that printer is not the new default.  Also needs to handle cups.HTTPError 404.
Comment 2 Tim Waugh 2006-12-08 09:14:52 EST
Please try 0.7.41-1.fc6 from updates-testing, like this:

yum --enablerepo=updates-testing update 'system-config-printer*'
Comment 3 Tim Waugh 2006-12-14 05:48:54 EST
Have you had a chance to try the test update package yet?
Comment 4 Fedora Update System 2007-01-05 13:20:12 EST
Fixed in update: system-config-printer-0.7.45-1.fc6

Note You need to log in before you can comment on or make changes to this bug.