Bug 217399 - USB floppy/key seen as valid storage devices during CD install.
USB floppy/key seen as valid storage devices during CD install.
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-11-27 14:09 EST by Jose De la Rosa
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-28 13:43:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jose De la Rosa 2006-11-27 14:09:06 EST
Description of problem:

USB Floppy/key are seen as valid storage devices during RHEL 4 CD install.

Version-Release number of selected component (if applicable):

RHEL 4 Gold, Kernel 2.6.9-5
RHEL 4.4, Kernel 2.6.9-42

How reproducible:

Disable virtual media on DRAC and disable local storage (remove disks or 
disable storage controller on BIOS). Attach a USB floppy or USB key. Perform 
OS installation via CD.

Steps to Reproduce:

1. Disable storage controller on BIOS or remove all drives from server.
2. Disable virtual media on DRAC.
3. Connect a USB key or USB floppy drive (with or without floppy) to server.
4. Begin RHEL 4 installation via CD. Boot with default paramaters (just hit 
5. Go through installation process. Skip media check.
6. Anaconda runs. Select language (English), select keyboard (US English).
7. During disk partitioning setup, select auto-partitioning.

Actual results:

Anaconda runs and starts the OS install process, thinking there is a valid 
storage device to install the OS onto. When it gets to the partitioning 
section, it detects that there are no valid devices to create file systems and 
displays the following message:

"An error has ocurred - no valid devices
 were found on which to create new file
 systems. Please check your hardware for
 the cause of this problem."

At this point, all I can do is reboot the system *** This is a problem because 
I do not get an option to load device drivers ***

Expected results:

The system should not detect any hard drives and ask the user to manually 
choose device drivers. The exact message is:

       --- Warning ---

No hard drives have been found.
You probably need to manually
choose device drivers for the
installation to succeed. Would
you like to select drivers now?

    -- yes --    -- no --

This is the message I get when I DO NOT have a USB key or USB floppy attached 
to the system. In this case, I am able to manually load device drivers that 
are not native to RHEL 4.

Additional info:

The way this problem came about was when we tried to install RHEL 4 to SAN 
(with all local storage disabled), using a newer Qlogic HBA. The driver for 
this HBA is not on the RHEL 4 install CD, and we did not get the option to 
load the driver manually (because it just so happened that we had a USB floppy 
attached to the system). When we detached the floppy drive and tried the 
install again, we got the warning above and then were able to load device 
drivers manually.
Comment 1 Jeremy Katz 2006-11-28 13:43:46 EST
You can say you need to load drivers with 'linux dd'.  If you know your device
isn't supported, this is the recommended way; not counting on the dialog not
detecting other drives.
Comment 2 Jeremy Katz 2006-12-07 20:55:44 EST
*** Bug 218783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.