Bug 2174 - Panel crashes when starting reversi.
Panel crashes when starting reversi.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-14 06:49 EDT by Kjartan Maraas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-28 07:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 1999-04-14 06:49:05 EDT
Turn on autohide in the panel configuration, start reversi
from the KDE menu and the panel crashes.

This is on a 5.9.8.1 system upgraded from 5.9.7c
Comment 1 Owen Taylor 1999-04-14 13:55:59 EDT
I could not reproduce this with 5.9.9
Comment 2 Kjartan Maraas 1999-04-15 04:33:59 EDT
Update. Upgraded to 5.9.9. I tried to start reversi from the KDE menu.
Nothing happens. Then clicked the foot-menu and it died. This
generates a core file that indicates a segfault in gen_util_applet.

(gdb) where
#0  0x4041a131 in __kill ()
#1  0x40419d86 in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x4041b467 in abort () at ../sysdeps/generic/abort.c:88
#3  0x4008a671 in g_logv ()
#4  0x4008a722 in g_log ()
#5  0x402efaaa in gdk_x_error ()
#6  0x403589e9 in _XError ()
#7  0x40357251 in _XReply ()
#8  0x40352cf1 in XSync ()
#9  0x402fbe4b in gdk_flush ()
#10 0x40257f68 in gtk_main ()
#11 0x4001afa9 in applet_widget_gtk_main ()
#12 0x804b31d in main ()
#13 0x40413cd3 in __libc_start_main (main=0x804b264 <main>, argc=3,
argv=0xbffffb94,
    init=0x804a710 <_init>, fini=0x804e6ac <_fini>,
rtld_fini=0x4000a180 <_dl_fini>, stack_end=0xbffffb8c)
    at ../sysdeps/generic/libc-start.c:78
(gdb)

Kjartan Maraas
Comment 3 Kjartan Maraas 1999-04-15 04:35:59 EDT
BTW. kreversi starts ok from the command line, but there are
some error messages.

Kjartan

Note You need to log in before you can comment on or make changes to this bug.