This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 21740 - date server leave connections open
date server leave connections open
Status: CLOSED DUPLICATE of bug 16729
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 09:58 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 16:16:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-05 09:58:29 EST
I have been using a RH 6.2 as a time server and it does not close the 
connections, this is a line of a netstat :
tcp        1      0 192.168.0.1:37          192.168.0.69:1044       
CLOSE_WAIT

I have to restart the server periodically because of this
Comment 1 Need Real Name 2000-12-23 19:50:38 EST
inetd is not closing the socket on builtins.

--- inetd.c	Sat Dec 23 16:49:10 2000
+++ inetd.c.orig	Tue Nov 23 11:31:53 1999
@@ -490,7 +490,6 @@
 	}
 	else {
 		sep->se_bi->bi_fn(ctrl, sep);
-		close(ctrl);
 	}
 }
Comment 2 Trond Eivind Glomsrxd 2001-01-25 13:38:41 EST

*** This bug has been marked as a duplicate of 16729 ***

Note You need to log in before you can comment on or make changes to this bug.